aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-04-21 09:58:49 +0800
committerKhem Raj <raj.khem@gmail.com>2020-04-20 21:45:13 -0700
commit8296d86695be4c56ee375124aefc6f307dc3ded2 (patch)
tree7d20020f3972d5f7f733cb2a0da15bbc649daaae /meta-python
parent345f610b12c1da240f69ef80de79b6c3d9a47fd9 (diff)
downloadmeta-openembedded-8296d86695be4c56ee375124aefc6f307dc3ded2.tar.gz
python3-jdcal: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-jdcal/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb14
2 files changed, 16 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jdcal/run-ptest b/meta-python/recipes-devtools/python/python3-jdcal/run-ptest
new file mode 100644
index 0000000000..5cec711696
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jdcal/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest
diff --git a/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb b/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb
index c8b5c953b6..46deeae158 100644
--- a/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb
@@ -7,9 +7,21 @@ HOMEPAGE = "https://github.com/phn/jdcal"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bd236e1f590973467a427bb354be0f46"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
SRC_URI[md5sum] = "e05bdb60fa80f25bc60e73e0c6b7c5dc"
SRC_URI[sha256sum] = "472872e096eb8df219c23f2689fc336668bdb43d194094b5cc1707e1640acfc8"
RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/test_jdcal.py ${D}${PTEST_PATH}/
+}