aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorPierre-Jean Texier <pjtexier@koncepto.io>2020-04-12 17:03:32 +0200
committerKhem Raj <raj.khem@gmail.com>2020-04-12 22:57:22 -0700
commit88742b214a041eb8cb9d2672c3fc2f3d2bd9fe3b (patch)
tree03945f66fc88bd57b357e28e79c9efdcac2e9b01 /meta-python
parent6218b1b8dadffa20c079e98ae2166fe95b4870f2 (diff)
downloadmeta-openembedded-88742b214a041eb8cb9d2672c3fc2f3d2bd9fe3b.tar.gz
python3-msgpack: consolidate into a single file
For details see [1] [1] - https://lists.openembedded.org/g/openembedded-devel/topic/72718415 Suggested-by: Tim Orling <ticotimo@gmail.com> Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-msgpack.inc15
-rw-r--r--meta-python/recipes-devtools/python/python3-msgpack_0.6.2.bb17
2 files changed, 15 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-msgpack.inc b/meta-python/recipes-devtools/python/python-msgpack.inc
deleted file mode 100644
index dba5dc44f3..0000000000
--- a/meta-python/recipes-devtools/python/python-msgpack.inc
+++ /dev/null
@@ -1,15 +0,0 @@
-SUMMARY = "MessagePack (de)serializer"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751"
-
-PYPI_PACKAGE = "msgpack"
-inherit pypi
-
-SRC_URI[md5sum] = "ba46fdee995565f40e332bd7eea882f1"
-SRC_URI[sha256sum] = "ea3c2f859346fcd55fc46e96885301d9c2f7a36d453f5d8f2967840efa1e1830"
-
-RDEPENDS_${PN}_class-target += "\
- ${PYTHON_PN}-io \
-"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-msgpack_0.6.2.bb b/meta-python/recipes-devtools/python/python3-msgpack_0.6.2.bb
index 096d7ddcb8..7cfaf1c513 100644
--- a/meta-python/recipes-devtools/python/python3-msgpack_0.6.2.bb
+++ b/meta-python/recipes-devtools/python/python3-msgpack_0.6.2.bb
@@ -1,2 +1,15 @@
-require python-msgpack.inc
-inherit setuptools3
+SUMMARY = "MessagePack (de)serializer"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751"
+
+PYPI_PACKAGE = "msgpack"
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "ba46fdee995565f40e332bd7eea882f1"
+SRC_URI[sha256sum] = "ea3c2f859346fcd55fc46e96885301d9c2f7a36d453f5d8f2967840efa1e1830"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-io \
+"
+
+BBCLASSEXTEND = "native nativesdk"