aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2020-04-27 16:53:44 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-27 17:58:54 -0700
commitb76313654f75f0d9af2ac8ae46804ce7e41efe7f (patch)
treef2643a40ca99de9a3edb2e34fa6930e5b7256c40 /meta-python
parent8c6ffb685b3e4a85e944c99135b5b4eb598666e3 (diff)
downloadmeta-openembedded-b76313654f75f0d9af2ac8ae46804ce7e41efe7f.tar.gz
python3-asn1crypto: add python3-numbers to RDEPENDS
The asn1crypto module relies on the fractions module from the standard library, which is contained in the python3-numbers package, but it is not in asn1crypto's RDEPENDS: |>>> import asn1crypto.pdf |Traceback (most recent call last): | File "<stdin>", line 1, in <module> | File "/usr/lib64/python3.8/site-packages/asn1crypto/pdf.py", line 10, in <module> | from .cms import CMSAttributeType, CMSAttribute | File "/usr/lib64/python3.8/site-packages/asn1crypto/cms.py", line 29, in <module> | from .algos import ( | File "/usr/lib64/python3.8/site-packages/asn1crypto/algos.py", line 26, in <module> | from .core import ( | File "/usr/lib64/python3.8/site-packages/asn1crypto/core.py", line 52, in <module> | from fractions import Fraction |ModuleNotFoundError: No module named 'fractions' Add it to fix the error. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb b/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb
index 1b03c666a4..0d38da9894 100644
--- a/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-asn1crypto_1.3.0.bb
@@ -18,6 +18,7 @@ RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-datetime \
${PYTHON_PN}-io \
${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
${PYTHON_PN}-shell \
"