aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-04-11 08:42:03 +0800
committerKhem Raj <raj.khem@gmail.com>2020-04-10 17:48:39 -0700
commitc7a4fb91bd5ec41a6faefbb7a1251a82949ca8a9 (patch)
tree65f34c299356b6d06f9af5d0e34724d314e7b113 /meta-python
parent00f298cf46954447b30b24c8e65d4625c16ce626 (diff)
downloadmeta-openembedded-c7a4fb91bd5ec41a6faefbb7a1251a82949ca8a9.tar.gz
python3-pyroute2: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyroute2/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-pyroute2_0.5.11.bb16
2 files changed, 18 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest b/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest
new file mode 100644
index 0000000000..5cec711696
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2_0.5.11.bb b/meta-python/recipes-devtools/python/python3-pyroute2_0.5.11.bb
index 58b538a45e..a4b8aa3988 100644
--- a/meta-python/recipes-devtools/python/python3-pyroute2_0.5.11.bb
+++ b/meta-python/recipes-devtools/python/python3-pyroute2_0.5.11.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
SRC_URI[md5sum] = "7005db01604663fc2ecc089925980e05"
SRC_URI[sha256sum] = "05e959f1a89d715158b91fe83b67946a4441e5e098cc225f4df78a3765ac4af2"
-inherit setuptools3 pypi
+inherit setuptools3 pypi ptest
RDEPENDS_${PN} += " \
${PYTHON_PN}-ctypes \
@@ -21,3 +21,17 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-shell \
${PYTHON_PN}-unixadmin \
"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-fcntl \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}