aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-04-01 16:35:46 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-01 15:11:15 -0700
commit1fed24e60373866e13ceb12157575c4e09d5f261 (patch)
treeb23b266c8559e837eb8f958a275353a33235a419 /meta-python
parent7227897d5d4eb1af442508689ceb09935449efbb (diff)
downloadmeta-openembedded-1fed24e60373866e13ceb12157575c4e09d5f261.tar.gz
pycryptodomex: cleanup recipe to use common include
PyCryptodome is "an almost drop-in replacement for the old PyCrypto library" and installs under "Crypto" package. In cases when both PyCryptodome and old PyCrypto are needed, there's PyCryptodomeX that installs under own name as "Cryptodome" package. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pycryptodome.inc2
-rw-r--r--meta-python/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb26
2 files changed, 4 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycryptodome.inc b/meta-python/recipes-devtools/python/python-pycryptodome.inc
index 31d1368b0f..63b4a4abb4 100644
--- a/meta-python/recipes-devtools/python/python-pycryptodome.inc
+++ b/meta-python/recipes-devtools/python/python-pycryptodome.inc
@@ -21,7 +21,7 @@ RDEPENDS_${PN}-tests += " \
PACKAGES =+ "${PN}-tests"
-FILES_${PN}-tests += " \
+FILES_${PN}-tests = " \
${PYTHON_SITEPACKAGES_DIR}/Crypto/SelfTest/ \
${PYTHON_SITEPACKAGES_DIR}/Crypto/SelfTest/__pycache__/ \
"
diff --git a/meta-python/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb b/meta-python/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb
index be6b10f3fb..e41c14b142 100644
--- a/meta-python/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pycryptodomex_3.9.4.bb
@@ -1,30 +1,10 @@
-SUMMARY = "Cryptographic library for Python"
-DESCRIPTION = "PyCryptodome is a self-contained Python package of low-level\
- cryptographic primitives."
-HOMEPAGE = "http://www.pycryptodome.org"
-LICENSE = "PD & BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=6dc0e2a13d2f25d6f123c434b761faba"
+require python-pycryptodome.inc
+inherit setuptools3
SRC_URI[md5sum] = "46ba513d95b6e323734074d960a7d57b"
SRC_URI[sha256sum] = "22d970cee5c096b9123415e183ae03702b2cd4d3ba3f0ced25c4e1aba3967167"
-inherit pypi
-inherit setuptools3
-
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-io \
- ${PYTHON_PN}-math \
-"
-
-RDEPENDS_${PN}-tests += " \
- ${PYTHON_PN}-unittest \
-"
-
-PACKAGES =+ "${PN}-tests"
-
-FILES_${PN}-tests += " \
+FILES_${PN}-tests = " \
${PYTHON_SITEPACKAGES_DIR}/Cryptodome/SelfTest/ \
${PYTHON_SITEPACKAGES_DIR}/Cryptodome/SelfTest/__pycache__/ \
"
-
-BBCLASSEXTEND = "native nativesdk"