aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authornick83ola <nick83ola@gmail.com>2020-03-25 06:22:07 +0000
committerKhem Raj <raj.khem@gmail.com>2020-03-25 06:52:29 -0700
commitc6fb8e3efbb14d138a3aee6cf31e6ae96d57b54f (patch)
tree446155138b58f889d0e4ba1a72fa64313b5b4ad7 /meta-python
parentd85d9c7a13aad23c43a0bccc23f03e98f312f11f (diff)
downloadmeta-openembedded-c6fb8e3efbb14d138a3aee6cf31e6ae96d57b54f.tar.gz
python3-matplotlib: multiple changes
* The license indicated in the setup.py is PSF not the BSD. Update LICENSE * added kiwisolver and cycler to the dependencies * add missing pkgconfig class * added native for the python dependencies to DEPENDS: the setuptools need to launch the required libraries to check if they are there * remove redundant PYPI_PACKAGE * add SECTION = "devel/python" * apply oe-stylize Signed-off-by: Nicola Lunghi <nick83ola@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib_3.1.1.bb32
1 files changed, 25 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.1.1.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.1.1.bb
index 824680c243..c638e27b14 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib_3.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.1.1.bb
@@ -4,16 +4,34 @@ Matplotlib is a Python 2D plotting library which produces \
publication-quality figures in a variety of hardcopy formats \
and interactive environments across platforms."
HOMEPAGE = "https://github.com/matplotlib/matplotlib"
-LICENSE = "BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74"
-
-DEPENDS = "python3-numpy-native python3-numpy freetype libpng python3-dateutil python3-pytz"
-RDEPENDS_${PN} = "python3-numpy freetype libpng python3-dateutil python3-pytz"
+SECTION = "devel/python"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "\
+ file://setup.py;beginline=275;endline=275;md5=2a114620e4e6843aa7568d5902501753 \
+ file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
+"
+DEPENDS = "\
+ freetype \
+ libpng \
+ python3-numpy-native \
+ python3-dateutil-native \
+ python3-pytz-native \
+"
SRC_URI[md5sum] = "f894af5564a588e880644123237251b7"
SRC_URI[sha256sum] = "1febd22afe1489b13c6749ea059d392c03261b2950d1d45c17e3aed812080c93"
-PYPI_PACKAGE = "matplotlib"
-inherit pypi setuptools3
+inherit pypi setuptools3 pkgconfig
+
+RDEPENDS_${PN} = "\
+ freetype \
+ libpng \
+ python3-numpy \
+ python3-pyparsing \
+ python3-cycler \
+ python3-dateutil \
+ python3-kiwisolver \
+ python3-pytz \
+"
BBCLASSEXTEND = "native"