aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-26 11:02:17 +0200
committerKhem Raj <raj.khem@gmail.com>2020-10-28 10:22:06 -0700
commit164a6030b0c39d5259ce304e1f4aced991d47639 (patch)
tree1af2892ebfb27e92891294f97e1f9297238aa5ce /meta-python
parent7ccadfb68ba86428e4db319e58b0af0c4bb76c71 (diff)
downloadmeta-openembedded-164a6030b0c39d5259ce304e1f4aced991d47639.tar.gz
python3-aiohttp: Upgrade 3.6.3 -> 3.7.1
Upgrade to release 3.7.1: - Fixed a type error caused by the conditional import of Protocol - Server doesn't send Content-Length for 1xx or 204 - Fix run_app typing - Always require typing_extensions library - Fix a variable-shadowing bug causing ThreadedResolver.resolve to return the resolved IP as the hostname in each record, which prevented validation of HTTPS connections - Added annotations to all public attributes - Fix flaky test_when_timeout_smaller_second - Ensure sending a zero byte file does not throw an exception - Fix a bug in web.run_app() about Python version checking on Windows License-Update: Update year Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiohttp_3.7.1.bb (renamed from meta-python/recipes-devtools/python/python3-aiohttp_3.6.3.bb)6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiohttp_3.6.3.bb b/meta-python/recipes-devtools/python/python3-aiohttp_3.7.1.bb
index 824bde5e25..8b5b1dd160 100644
--- a/meta-python/recipes-devtools/python/python3-aiohttp_3.6.3.bb
+++ b/meta-python/recipes-devtools/python/python3-aiohttp_3.7.1.bb
@@ -2,10 +2,10 @@ SUMMARY = "Async http client/server framework"
DESCRIPTION = "Asynchronous HTTP client/server framework for asyncio and Python"
HOMEPAGE = "https://github.com/aio-libs/aiohttp"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cf056e8e7a0a5477451af18b7b5aa98c"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3bf3d48554bdca1ea7fdb48de378c2ca"
-SRC_URI[md5sum] = "13d02dc8379207dde1f6966d1fc5083d"
-SRC_URI[sha256sum] = "698cd7bc3c7d1b82bb728bae835724a486a8c376647aec336aa21a60113c3645"
+SRC_URI[md5sum] = "ed78633cc420b29d3b61c7d877dc0901"
+SRC_URI[sha256sum] = "04f9d70f6c4d089be5068d7df6281e638f6820d4f1b1ec3dc012b0b43fa997d2"
PYPI_PACKAGE = "aiohttp"
inherit setuptools3 pypi