aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-07 17:32:04 +0300
committerArmin Kuster <akuster808@gmail.com>2021-04-08 13:13:29 -0700
commitbdc87e70c15976c099cda8ac074e94b9d1f42585 (patch)
treeae039f8d86bce457a7a9341153ce7b08d342e5d0 /meta-python
parent04849afa784feea8f0fd9ede932adc0f5a8cf8e9 (diff)
downloadmeta-openembedded-bdc87e70c15976c099cda8ac074e94b9d1f42585.tar.gz
python3-sqlalchemy: Upgrade 1.4.5 -> 1.4.6
Upgrade to release 1.4.6: orm: - Fixed regression where a deprecated form of Query.join() were used, passing a series of entities to join from without any ON clause in a single Query.join() call, would fail to function correctly. - Fixed critical regression where the Query.yield_per() method in the ORM would set up the internal Result to yield chunks at a time, however made use of the new Result.unique() method which uniques across the entire result. sql: - Fixed further regressions in the same area as that of #6173 released in 1.4.5, where a “postcompile” parameter, again most typically those used for LIMIT/OFFSET rendering in Oracle and SQL Server, would fail to be processed correctly if the same parameter rendered in multiple places in the statement. - Executing a Subquery using Connection.execute() is deprecated and will emit a deprecation warning; this use case was an oversight that should have been removed from 1.4. schema: - The Table object now raises an informative error message if it is instantiated without passing at least the Table.name and Table.metadata arguments positionally. Previously, if these were passed as keyword arguments, the object would silently fail to initialize correctly. mypy: - Applied a series of refactorings and fixes to accommodate for Mypy "incremental" mode across multiple files, which previously was not taken into account. In this mode the Mypy plugin has to accommodate Python datatypes expressed in other files coming in with less information than they have on a direct run. - Fixed issue where the Mypy plugin would fail to interpret the "collection_class" of a relationship if it were a callable and not a class. Also improved type matching and error reporting for collection-oriented relationships. asyncio: - Added accessors .sqlstate and synonym .pgcode to the .orig attribute of the SQLAlchemy exception class raised by the asyncpg DBAPI adapter, that is, the intermediary exception object that wraps on top of that raised by the asyncpg library itself, but below the level of the SQLAlchemy dialect. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> (cherry picked from commit b649e45ab1f87346c535ef77052343594391bd39) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.6.bb (renamed from meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.5.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.5.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.6.bb
index 206a9ab3b0..4d5aa33d1a 100644
--- a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.5.bb
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.6.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.sqlalchemy.org/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3359ed561ac16aaa25b6c6eff84df595"
-SRC_URI[sha256sum] = "1294f05916c044631fd626a4866326bbfbd17f62bd37510d000afaef4b35bd74"
+SRC_URI[sha256sum] = "193c3ca465fbc68de071995a461ab535466f041089d372ee6a6f0aae7b9307e6"
PYPI_PACKAGE = "SQLAlchemy"
inherit pypi setuptools3