aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-03-25 15:34:36 +0200
committerKhem Raj <raj.khem@gmail.com>2021-03-26 10:32:33 -0700
commitd0cccb374ceccd315df6e665d1e55c709d6acc1d (patch)
treec8e65cfd277afe2adfd029ece0abeac883baaa3f /meta-python
parent0715e83336560fdb1d9ad5d6dc6a17c267c62c2a (diff)
downloadmeta-openembedded-d0cccb374ceccd315df6e665d1e55c709d6acc1d.tar.gz
python3-djangorestframework: Upgrade 3.12.2 -> 3.12.3
Upgrade to release 3.12.3: - Properly handle ATOMIC_REQUESTS when multiple database configurations are used. - Bypass COUNT query when LimitOffsetPagination is configured but pagination params are not included on the request. - Respect allow_null=True on DecimalField. - Allow title cased "Yes"/"No" values with BooleanField. - Add PageNumberPagination.get_page_number() method for overriding behavior. - Fixed rendering of timedelta values in OpenAPI schemas, when present as default, min, or max fields. - Render JSONFields with indentation in browsable API forms. - Remove unnecessary database query in admin Token views. - Raise validation errors when bools are passed to PrimaryKeyRelatedField fields, instead of casting to ints. - Don't include model properties as automatically generated ordering fields with OrderingFilter. - Use deque instead of list for tracking throttling .history. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-djangorestframework_3.12.3.bb (renamed from meta-python/recipes-devtools/python/python3-djangorestframework_3.12.2.bb)4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-djangorestframework_3.12.2.bb b/meta-python/recipes-devtools/python/python3-djangorestframework_3.12.3.bb
index 6742b87b2c..a75d3f18cd 100644
--- a/meta-python/recipes-devtools/python/python3-djangorestframework_3.12.2.bb
+++ b/meta-python/recipes-devtools/python/python3-djangorestframework_3.12.3.bb
@@ -5,8 +5,8 @@ HOMEPAGE = "https://pypi.python.org/pypi/djangorestframework"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.md;md5=7879a5a716147a784f7e524c9cf103c1"
-SRC_URI[md5sum] = "e70d58ee2f83f11d4efe33162bb8af3b"
-SRC_URI[sha256sum] = "0898182b4737a7b584a2c73735d89816343369f259fea932d90dc78e35d8ac33"
+SRC_URI[sha256sum] = "2fbbd5c28a1aaa1ad0b721b29e916797fc9aba9f9b3e7619da11c674880fc7aa"
+
PYPI_PACKAGE = "djangorestframework"
inherit pypi setuptools3