aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-12 17:02:09 +0300
committerArmin Kuster <akuster808@gmail.com>2021-04-17 06:46:24 -0700
commitf220c5a6394cc3f25fd61e9dd7fb81701fa80ffd (patch)
tree03a714f1d2b19f0b4effa7043af9d707ada25226 /meta-python
parent70f8006b1637dd838f20832168d52a95a75e8786 (diff)
downloadmeta-openembedded-f220c5a6394cc3f25fd61e9dd7fb81701fa80ffd.tar.gz
python3-sqlalchemy: Upgrade 1.4.6 -> 1.4.7
Upgrade to release 1.4.7: orm: - Fixed regression where the subqueryload() loader strategy would fail to correctly accommodate sub-options, such as a defer() option on a column, if the “path” of the subqueryload were more than one level deep. - Fixed regression where the merge_frozen_result() function relied upon by the dogpile.caching example was not included in tests and began failing due to incorrect internal arguments. - Fixed critical regression where the Session could fail to "autobegin" a new transaction when a flush occurred without an existing transaction in place, implicitly placing the Session into legacy autocommit mode which commit the transaction. The Session now has a check that will prevent this condition from occurring, in addition to repairing the flush issue. - Fixed regression where the ORM compilation scheme would assume the function name of a hybrid property would be the same as the attribute name in such a way that an AttributeError would be raised, when it would attempt to determine the correct name for each element in a result tuple. - Fixed critical regression caused by the new feature added as part of #1763, eager loaders are invoked on unexpire operations. The new feature makes use of the "immediateload" eager loader strategy as a substitute for a collection loading strategy, which unlike the other “post-load” strategies was not accommodating for recursive invocations between mutually-dependent relationships, leading to recursion overflow errors. engine: - Fixed up the behavior of the Row object when dictionary access is used upon it, meaning converting to a dict via dict(row) or accessing members using strings or other objects i.e. row["some_key"] works as it would with a dictionary, rather than raising TypeError as would be the case with a tuple, whether or not the C extensions are in place sql: - Enhanced the "expanding" feature used for ColumnOperators.in_() operations to infer the type of expression from the right hand list of elements, if the left hand side does not have any explicit type set up. This allows the expression to support stringification among other things. In 1.3, "expanding" was not automatically used for ColumnOperators.in_() expressions, so in that sense this change fixes a behavioral regression. - Fixed the "stringify" compiler to support a basic stringification of a "multirow" INSERT statement, i.e. one with multiple tuples following the VALUES keyword. schema: - Fixed regression where usage of a token in the Connection.execution_options.schema_translate_map dictionary which contained special characters such as braces would fail to be substituted properly. Use of square bracket characters [] is now explicitly disallowed as these are used as a delimiter character in the current implementation. mypy: - Fixed issue in Mypy plugin where the plugin wasn't inferring the correct type for columns of subclasses that don’t directly descend from TypeEngine, in particular that of TypeDecorator and UserDefinedType. misc: - Added a new flag to DefaultDialect called supports_schema; third party dialects may set this flag to True to enable SQLAlchemy's schema-level tests when running the test suite for a third party dialect. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> (cherry picked from commit bc55118cf6e176b19ccebb86de85c51ad711c217) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.7.bb (renamed from meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.6.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.6.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.7.bb
index 4d5aa33d1a..883b2660b0 100644
--- a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.6.bb
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.4.7.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.sqlalchemy.org/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3359ed561ac16aaa25b6c6eff84df595"
-SRC_URI[sha256sum] = "193c3ca465fbc68de071995a461ab535466f041089d372ee6a6f0aae7b9307e6"
+SRC_URI[sha256sum] = "84115f97d88c8ccf26db81b7997c5f5de9ae360e0785ef859d0987794495f0a9"
PYPI_PACKAGE = "SQLAlchemy"
inherit pypi setuptools3