aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-04-13 10:16:52 -0300
committerArmin Kuster <akuster808@gmail.com>2016-05-02 14:03:02 -0700
commitfc3b141cbcd3f91fbb3b6fbfc643deb0cdadcbf1 (patch)
treeb444750664f2985a0e00f021d73219fa6e10b36d /meta-python
parent93aa4aa192a4a23485126d0a1770812842e528a6 (diff)
downloadmeta-openembedded-fc3b141cbcd3f91fbb3b6fbfc643deb0cdadcbf1.tar.gz
python-bcrypt: Add recipe for version 2.0.0
It's a modern password hashing for your software and your servers. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-bcrypt_2.0.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-bcrypt_2.0.0.bb b/meta-python/recipes-devtools/python/python-bcrypt_2.0.0.bb
new file mode 100644
index 0000000000..3cbe33eb52
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-bcrypt_2.0.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Modern password hashing for your software and your servers."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e19d0fe40c5ce4109e6bcbf4aab2a5bd"
+
+DEPENDS = "python-cffi-native"
+
+SRC_URI[md5sum] = "e7fb17be46904cdb2ae6a062859ee58c"
+SRC_URI[sha256sum] = "8b2d197ef220d10eb74625dde7af3b10daa973ae9a1eadd6366f763fad4387fa"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "\
+ python-cffi \
+ python-six \
+"