aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-12 10:41:52 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-14 08:17:25 -0700
commit103354c765b833958c3fffc4887d0e49768b1d35 (patch)
tree63320dbcbfee621884269f1e4919c5bd06ce225d /meta-python
parentd7458db05456fb21be0204cda70fc137a6ff8957 (diff)
downloadmeta-openembedded-103354c765b833958c3fffc4887d0e49768b1d35.tar.gz
python3-web3: new package
Add a recipe for web3: a library for interacting with Ethereum. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-web3_5.29.0.bb20
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 2bf26fc69a..d089089391 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -443,6 +443,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-visitor \
python3-waitress \
python3-watchdog \
+ python3-web3 \
python3-webcolors \
python3-webencodings \
python3-websocket-client \
diff --git a/meta-python/recipes-devtools/python/python3-web3_5.29.0.bb b/meta-python/recipes-devtools/python/python3-web3_5.29.0.bb
new file mode 100644
index 0000000000..660d4f6f0f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-web3_5.29.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "A Python library for interacting with Ethereum."
+HOMEPAGE = "https://github.com/ethereum/web3.py"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dc2732bdc5e50382737979791cbb3b7"
+
+SRC_URI[sha256sum] = "a78acc0f0150013755398ae185c8c7063d9db0777aa09733de22242a746bd30c"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-aiohttp \
+ python3-distutils \
+ python3-eth-account \
+ python3-idna \
+ python3-lru-dict \
+ python3-requests \
+ python3-setuptools \
+ python3-websockets \
+"