aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-05-08 16:40:20 +0800
committerTrevor Gamblin <tvgamblin@gmail.com>2022-05-19 09:50:56 -0400
commit172ac082dc7477095de24549c7ba2a77fb4e53fc (patch)
tree50a98309c892ef73b374bfe4c39ff758a7cd28bc /meta-python
parent643bad4d31188fa78c8cee406da397af6bcbe7c9 (diff)
downloadmeta-openembedded-172ac082dc7477095de24549c7ba2a77fb4e53fc.tar.gz
python3-aiohue: upgrade 3.0.11 -> 4.4.1
add dependence: python3-awesomeversion Changelog from 3.0.11 to 4.4.1 ============================== Switch to limit per host on tcp connector Delay initializing workaround dict Bump black from 21.12b0 to 22.1.0 Put back asyncio-throttle because still in use for v1 API Mac address got lost in translation Update to final models and fix parser errors Fix python 3.9 compatibility Fix typo in button events handler Add diagnostics feature Small follow up fix in event logic Allow motion sensor state to be null/none when sensor is disabled Add basic tests Fix float int conversion Fix race condition(s) while adding/removing a light/device Loosen up a bit on parser errors Fix button workaround Add setting effect feature on light Add missing parameters to the grouped_light set_state Fix typo in default enum member Add timed effects feature to light Add support for aggregated grouped_lights commands Hide dependencies in release-drafter Fix and cleanup of button workaround code Fix typo in timed effects featur Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <tvgamblin@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiohue_4.4.1.bb (renamed from meta-python/recipes-devtools/python/python3-aiohue_3.0.11.bb)3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiohue_3.0.11.bb b/meta-python/recipes-devtools/python/python3-aiohue_4.4.1.bb
index 47d9964b0e..b3a88fb677 100644
--- a/meta-python/recipes-devtools/python/python3-aiohue_3.0.11.bb
+++ b/meta-python/recipes-devtools/python/python3-aiohue_4.4.1.bb
@@ -4,7 +4,7 @@ SECTION = "devel/python"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=dab31a1d28183826937f4b152143a33f"
-SRC_URI[sha256sum] = "31c0b90d7dc2b62f5e1a93e78b2c0d6360ef6c0a87485c217a4f394c937fce7d"
+SRC_URI[sha256sum] = "fa3bb0cf68aefdd0710704443c896abda69ae227500ad9539ac6c3d1d6dad804"
inherit pypi setuptools3
@@ -12,4 +12,5 @@ RDEPENDS:${PN} += " \
${PYTHON_PN}-aiohttp \
${PYTHON_PN}-asyncio-throttle \
${PYTHON_PN}-profile \
+ ${PYTHON_PN}-awesomeversion \
"