aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2023-03-09 13:07:44 +0800
committerKhem Raj <raj.khem@gmail.com>2023-03-09 09:54:04 -0800
commit4f45bf76d26d1b245a8a58f062d6f5d7bf5e2f68 (patch)
tree7f7445b8c22703127c66c3d6b7affad1806543d8 /meta-python
parenta393e5b30dd66e6d1b8798e7a33c82a1ab15cdc3 (diff)
downloadmeta-openembedded-4f45bf76d26d1b245a8a58f062d6f5d7bf5e2f68.tar.gz
python3-rich: add recipe
Rich is a Python library for rich text and beautiful formatting in the terminal. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-extended/python-rich/python3-rich_13.3.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-rich/python3-rich_13.3.2.bb b/meta-python/recipes-extended/python-rich/python3-rich_13.3.2.bb
new file mode 100644
index 0000000000..1cb90c5685
--- /dev/null
+++ b/meta-python/recipes-extended/python-rich/python3-rich_13.3.2.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Rich is a Python library for rich text and beautiful formatting in the terminal"
+DESCRIPTION = "The Rich API makes it easy to add color and style to terminal output. \
+Rich can also render pretty tables, progress bars, markdown, syntax highlighted source code, \
+tracebacks, and more."
+HOMEPAGE="https://github.com/Textualize/rich"
+SECTION = "devel/python"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b5f0b94fbc94f5ad9ae4efcf8a778303"
+
+SRC_URI[sha256sum] = "91954fe80cfb7985727a467ca98a7618e5dd15178cc2da10f553b36a93859001"
+
+inherit pypi python_poetry_core
+
+RDEPENDS:${PN} = "${PYTHON_PN}-pygments"