aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-03-15 22:08:33 +0800
committerKhem Raj <raj.khem@gmail.com>2023-03-17 07:06:55 -0700
commit54585d86f545ebb4285556e3060278680559c81a (patch)
treed3990ab23283846815f52338fcb364140ce47928 /meta-python
parentf1c384d6b2c27d879731df64091537e89bdfdcca (diff)
downloadmeta-openembedded-54585d86f545ebb4285556e3060278680559c81a.tar.gz
python3-pymodbus: upgrade 3.1.3 -> 3.2.0
Changelog: ========= Add value <-> registers converter helpers. (#1413) Add pre-commit config (#1406) Make baud rate configurable for examples (#1410) Clean __init_ and update log module. (#1411) Simulator add calls functionality. (#1390) Add note about not being thread safe. (#1404) Update docker-publish.yml Forward retry_on_empty and retries by calling transaction (#1401) serial sync recv interval (#1389) Add tests for writing multiple writes with a single value (#1402) Enable mypy in CI (#1388) Limit use of Singleton. (#1397) Cleanup interfaces (#1396) Add request names. (#1391) Simulator, register look and feel. (#1387) Fix enum for REPL server (#1384) Remove unneeded attribute (#1383) Fix mypy errors in reactive server (#1381) remove nosec (#1379) Fix type hints for http_server (#1369) Merge pull request #1380 from pymodbus-dev/requirements remove second client instance in async mode. (#1367) Pin setuptools to prevent breakage with Version including "X" (#1373) Lint and type hints for REPL (#1364) Clean mixin execute (#1366) Remove unused setup_commands.py. (#1362) Run black on top-level files and /doc (#1361) repl config path (#1359) Fix NoReponse -> NoResponse (#1358) Make whole main async. (#1355) Fix more typing issues (#1351) Test sync task (#1341) Fixed text in ModbusClientMixin's writes (#1352) lint /doc (#1345) Remove unused linters (#1344) Allow log level as string or integer. (#1343) Sync serial, clean recv. (#1340) Test server task, async completed (#1318) main() should be sync (#1339) Bug: Fixed caused by passing wrong arg (#1336) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymodbus_3.2.0.bb (renamed from meta-python/recipes-devtools/python/python3-pymodbus_3.1.3.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymodbus_3.1.3.bb b/meta-python/recipes-devtools/python/python3-pymodbus_3.2.0.bb
index 3750f5781e..d792fdf970 100644
--- a/meta-python/recipes-devtools/python/python3-pymodbus_3.1.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pymodbus_3.2.0.bb
@@ -4,7 +4,7 @@ LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2c2223d66c7e674b40527b5a4c35bd76"
DEPENDS += "python3-six-native"
-SRC_URI[sha256sum] = "714e5d6b7e28c4016a94346e73033aff276b6ce8bd22e470ba4fd8b982e08a98"
+SRC_URI[sha256sum] = "5769ac9a00ffc154e1761c69299c1968dcab1c2a61741b1caff89c4aea81dbcf"
S = "${WORKDIR}/pymodbus-${PV}"
inherit pypi setuptools3