aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2021-08-25 10:33:36 -0400
committerKhem Raj <raj.khem@gmail.com>2021-08-26 09:57:25 -0700
commite8247f6b28c0e2ada7321363674cfb8b3c822e38 (patch)
treef885580a2dcd091c1e1ab79c0c49408f3136287b /meta-python
parentea86c829bbe6836da1210b9b8e4ab1ded5381e8e (diff)
downloadmeta-openembedded-e8247f6b28c0e2ada7321363674cfb8b3c822e38.tar.gz
python3-gunicorn: tweak run-ptest, add RDEPENDS
gunicorn relies on eventlet and gevent for its ptests, and it also requires a non-empty /etc/resolv.conf for one of those tests. Add those two modules to RDEPENDS for the recipe, and add an echo in run-ptest to make sure that there is something basic in /etc/resolv.conf before the test actually runs. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-gunicorn/run-ptest4
-rw-r--r--meta-python/recipes-devtools/python/python3-gunicorn_20.1.0.bb2
2 files changed, 6 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gunicorn/run-ptest b/meta-python/recipes-devtools/python/python3-gunicorn/run-ptest
index b63c4de0d9..98d73fa037 100644
--- a/meta-python/recipes-devtools/python/python3-gunicorn/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-gunicorn/run-ptest
@@ -1,3 +1,7 @@
#!/bin/sh
+# there needs to be something in /etc/resolv.conf for the gunicorn
+# ptests to work, so make sure there's at least one nameserver line
+echo "nameserver 8.8.8.8" >> /etc/resolv.conf
+
pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-gunicorn_20.1.0.bb b/meta-python/recipes-devtools/python/python3-gunicorn_20.1.0.bb
index 38353c4736..f381b9df2b 100644
--- a/meta-python/recipes-devtools/python/python3-gunicorn_20.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-gunicorn_20.1.0.bb
@@ -12,6 +12,8 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-eventlet \
+ ${PYTHON_PN}-gevent \
${PYTHON_PN}-pytest \
"