aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2016-11-02 15:26:58 +0800
committerArmin Kuster <akuster808@gmail.com>2016-11-29 08:22:21 -0800
commit9869a2d7890eb1bbf9408e9a0b18fdd63e3160c8 (patch)
treec276d7dc94c6009c7af53e3af4bb836b4bebd802 /meta-python
parentf169b4043e4cfe389caae2f7cfbec0e8b8772a33 (diff)
downloadmeta-openembedded-9869a2d7890eb1bbf9408e9a0b18fdd63e3160c8.tar.gz
python-m2crypto: inherit siteinfo
In recipe of python-m2crypto, it uses var SITEINFO_BITS which is from siteinfo.bbclass. Inherit siteinfo.bbclass to avoid compile error: | .../tmp/sysroots/qemumips64/usr/include/openssl/opensslconf.h:47: | Error: CPP #error ""Unknown __WORDSIZE detected"". | Use the -cpperraswarn option to continue swig processing. | error: command 'swig' failed with exit status 1 Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 1e3fe19b5bfb8beef9f9f7d8fda32c61fe0ed123) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb b/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb
index 73d8bb1278..ab665d4798 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb
+++ b/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb
@@ -10,7 +10,7 @@ SRC_URI[sha256sum] = "1ac3b6eafa5ff7e2a0796675316d7569b28aada45a7ab74042ad089d15
SRC_URI += "file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch "
PYPI_PACKAGE = "M2Crypto"
-inherit pypi setuptools
+inherit pypi setuptools siteinfo
DEPENDS += "openssl swig-native"