aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-22 16:01:16 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:27:36 +0200
commit559ec4040e9b2841e986a77bdaf7acd21e15937b (patch)
tree6dd25ff86a5a9d2c0675336823835df1470c3e36 /meta-python
parent445e595c9dc01d475df8d9ffd8b6823c1d2c4d6a (diff)
downloadmeta-openembedded-559ec4040e9b2841e986a77bdaf7acd21e15937b.tar.gz
python-cryptography: Extend recipe to support Python 3
- Add Python 3 recipe - Change DEPENDS and RDEPENDS code style - Add native and nativesdk to BBCLASSEXTEND Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography.inc48
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_1.4.bb53
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography_1.4.bb10
4 files changed, 70 insertions, 43 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography.inc b/meta-python/recipes-devtools/python/python-cryptography.inc
new file mode 100644
index 0000000000..d4767b1d95
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography.inc
@@ -0,0 +1,48 @@
+SUMMARY = "Provides cryptographic recipes and primitives to python developers"
+LICENSE = "Apache-2.0 | BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
+
+DEPENDS += " \
+ ${PYTHON_PN}-cffi \
+ ${PYTHON_PN}-cffi-native \
+ ${PYTHON_PN}-pyasn1 \
+ ${PYTHON_PN}-six \
+"
+
+SRC_URI[md5sum] = "a9763e3831cc7cdb402c028fac1ceb39"
+SRC_URI[sha256sum] = "bb149540ed90c4b2171bf694fe6991d6331bc149ae623c8ff419324f4222d128"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-cffi \
+ ${PYTHON_PN}-idna \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pyasn1 \
+ ${PYTHON_PN}-pycparser \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-threading \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PN} \
+ ${PYTHON_PN}-cryptography-vectors \
+ ${PYTHON_PN}-iso8601 \
+ ${PYTHON_PN}-pretend \
+ ${PYTHON_PN}-pytest \
+"
+
+inherit ptest
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ install -d ${D}${PTEST_PATH}/tests/hazmat
+ cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
+}
+
+FILES_${PN}-dbg += " \
+ ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-cryptography_1.4.bb b/meta-python/recipes-devtools/python/python-cryptography_1.4.bb
index a6b5bd0888..b05c615101 100644
--- a/meta-python/recipes-devtools/python/python-cryptography_1.4.bb
+++ b/meta-python/recipes-devtools/python/python-cryptography_1.4.bb
@@ -1,49 +1,16 @@
-SUMMARY = "Provides cryptographic recipes and primitives to Python developers"
-LICENSE = "Apache-2.0 | BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
-DEPENDS += " python-cffi-native python-cffi python-enum34 python-six python-pyasn1"
-SRCNAME = "cryptography"
-
-SRC_URI = "file://run-ptest"
-
-SRC_URI[md5sum] = "a9763e3831cc7cdb402c028fac1ceb39"
-SRC_URI[sha256sum] = "bb149540ed90c4b2171bf694fe6991d6331bc149ae623c8ff419324f4222d128"
-
inherit pypi setuptools
+require python-cryptography.inc
-RDEPENDS_${PN} = "\
- python-pyasn1\
- python-six\
- python-cffi\
- python-enum34\
- python-setuptools\
- python-pycparser\
- python-subprocess\
- python-threading\
- python-numbers\
- python-contextlib\
- python-ipaddress\
- python-pyasn1\
- python-idna\
+SRC_URI += " \
+ file://run-ptest \
"
-RDEPENDS_${PN}-ptest = "\
- ${PN}\
- python-pytest\
- python-pretend\
- python-iso8601\
- python-cryptography-vectors\
+DEPENDS += " \
+ ${PYTHON_PN}-enum34 \
"
-inherit ptest
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
- cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
- install -d ${D}${PTEST_PATH}/tests/hazmat
- cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
-}
-
-FILES_${PN}-dbg += " \
- ${libdir}/python2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
- "
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-contextlib \
+ ${PYTHON_PN}-enum34 \
+ ${PYTHON_PN}-ipaddress \
+"
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/run-ptest b/meta-python/recipes-devtools/python/python3-cryptography/run-ptest
new file mode 100644
index 0000000000..0ba239c2a4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cryptography/run-ptest
@@ -0,0 +1,2 @@
+#!/bin/sh
+py.test
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_1.4.bb b/meta-python/recipes-devtools/python/python3-cryptography_1.4.bb
new file mode 100644
index 0000000000..f807042ec0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cryptography_1.4.bb
@@ -0,0 +1,10 @@
+inherit pypi setuptools3
+require python-cryptography.inc
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-lang \
+"