aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-22 16:01:19 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:27:36 +0200
commit775a576d2e62d17f4a4b4c24e117ab5241c646de (patch)
tree2bc893b7cdde315b6dda8de662a3a56a55a0ef14 /meta-python
parent96b167037b4d329cc37c3368de99ddc517bf19ee (diff)
downloadmeta-openembedded-775a576d2e62d17f4a4b4c24e117ab5241c646de.tar.gz
python-pycparser: Extend recipe to support Python 3
- Add Python 3 recipe - Add native and nativesdk to BBCLASSEXTEND Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pycparser.inc8
-rw-r--r--meta-python/recipes-devtools/python/python-pycparser_2.14.bb10
-rw-r--r--meta-python/recipes-devtools/python/python3-pycparser_2.14.bb2
3 files changed, 11 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycparser.inc b/meta-python/recipes-devtools/python/python-pycparser.inc
new file mode 100644
index 0000000000..bf3b757988
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycparser.inc
@@ -0,0 +1,8 @@
+SUMMARY = "Parser of the C language, written in pure Python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8fb364772b1441821d391591f340c35a"
+
+SRC_URI[md5sum] = "a2bc8d28c923b4fe2b2c3b4b51a4f935"
+SRC_URI[sha256sum] = "7959b4a74abdc27b312fed1c21e6caf9309ce0b29ea86b591fd2e99ecdf27f73"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pycparser_2.14.bb b/meta-python/recipes-devtools/python/python-pycparser_2.14.bb
index 18006ca6a5..adbc1a8f46 100644
--- a/meta-python/recipes-devtools/python/python-pycparser_2.14.bb
+++ b/meta-python/recipes-devtools/python/python-pycparser_2.14.bb
@@ -1,10 +1,2 @@
-SUMMARY = "Parser of the C language, written in pure Python"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=8fb364772b1441821d391591f340c35a"
-
-SRC_URI[md5sum] = "a2bc8d28c923b4fe2b2c3b4b51a4f935"
-SRC_URI[sha256sum] = "7959b4a74abdc27b312fed1c21e6caf9309ce0b29ea86b591fd2e99ecdf27f73"
-
inherit pypi setuptools
-
-BBCLASSEXTEND = "native"
+require python-pycparser.inc
diff --git a/meta-python/recipes-devtools/python/python3-pycparser_2.14.bb b/meta-python/recipes-devtools/python/python3-pycparser_2.14.bb
new file mode 100644
index 0000000000..b30db54c51
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pycparser_2.14.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-pycparser.inc