aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-22 16:01:26 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:27:38 +0200
commit83fb5cc2dbdcca4aae35a8069ba9a77d47e149c3 (patch)
tree1aa9d386ea49f306c4256f766d63f7dce8ace378 /meta-python
parent9dda62361853eb8af03587b7b6261dec81752af7 (diff)
downloadmeta-openembedded-83fb5cc2dbdcca4aae35a8069ba9a77d47e149c3.tar.gz
python-py: Extend recipe to support Python 3
- Add Python 3 recipe - Add native and nativesdk to BBCLASSEXTEND Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-py.inc8
-rw-r--r--meta-python/recipes-devtools/python/python-py_1.4.31.bb8
-rw-r--r--meta-python/recipes-devtools/python/python3-py_1.4.31.bb2
3 files changed, 11 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python-py.inc b/meta-python/recipes-devtools/python/python-py.inc
new file mode 100644
index 0000000000..9e33b168b2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-py.inc
@@ -0,0 +1,8 @@
+SUMMARY = "Library with cross-python path, ini-parsing, io, code, log facilities"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a6bb0320b04a0a503f12f69fea479de9"
+
+SRC_URI[md5sum] = "5d2c63c56dc3f2115ec35c066ecd582b"
+SRC_URI[sha256sum] = "a6501963c725fc2554dabfece8ae9a8fb5e149c0ac0a42fd2b02c5c1c57fc114"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-py_1.4.31.bb b/meta-python/recipes-devtools/python/python-py_1.4.31.bb
index 592bc04e25..5ad2c19766 100644
--- a/meta-python/recipes-devtools/python/python-py_1.4.31.bb
+++ b/meta-python/recipes-devtools/python/python-py_1.4.31.bb
@@ -1,8 +1,2 @@
-SUMMARY = "Library with cross-python path, ini-parsing, io, code, log facilities"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=a6bb0320b04a0a503f12f69fea479de9"
-
-SRC_URI[md5sum] = "5d2c63c56dc3f2115ec35c066ecd582b"
-SRC_URI[sha256sum] = "a6501963c725fc2554dabfece8ae9a8fb5e149c0ac0a42fd2b02c5c1c57fc114"
-
inherit pypi setuptools
+require python-py.inc
diff --git a/meta-python/recipes-devtools/python/python3-py_1.4.31.bb b/meta-python/recipes-devtools/python/python3-py_1.4.31.bb
new file mode 100644
index 0000000000..0ee373d24c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-py_1.4.31.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-py.inc