aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-17 10:17:48 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:49:28 +0200
commitb7ab1526c2ec3b09795389050035aab7f961bf68 (patch)
tree576c31386739e1753336183941257317009b3677 /meta-python
parent25b5e35df5c4d61ac9ba44cf443ef2d68a16fc2c (diff)
downloadmeta-openembedded-b7ab1526c2ec3b09795389050035aab7f961bf68.tar.gz
python-jsonschema, python3-jsonschema: Add recipe for version 2.5.1
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema.inc26
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema_2.5.1.bb8
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb6
3 files changed, 40 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonschema.inc b/meta-python/recipes-devtools/python/python-jsonschema.inc
new file mode 100644
index 0000000000..3466457e09
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-jsonschema.inc
@@ -0,0 +1,26 @@
+SUMMARY = "An implementation of JSON Schema validation for Python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8"
+
+SRC_URI[md5sum] = "374e848fdb69a3ce8b7e778b47c30640"
+SRC_URI[sha256sum] = "36673ac378feed3daa5956276a829699056523d7961027911f064b52255ead41"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-lang \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-re \
+ ${PYTHON_PN}-rfc3987 \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-strict-rfc3339 \
+ ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-textutils \
+ ${PYTHON_PN}-unittest \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-jsonschema_2.5.1.bb b/meta-python/recipes-devtools/python/python-jsonschema_2.5.1.bb
new file mode 100644
index 0000000000..3bb5220188
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-jsonschema_2.5.1.bb
@@ -0,0 +1,8 @@
+inherit pypi setuptools
+require python-jsonschema.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-argparse \
+ ${PYTHON_PN}-contextlib \
+ ${PYTHON_PN}-functools32 \
+"
diff --git a/meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb b/meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb
new file mode 100644
index 0000000000..5aaee682b6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsonschema_2.5.1.bb
@@ -0,0 +1,6 @@
+inherit pypi setuptools3
+require python-jsonschema.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-misc \
+"