aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorAlexandru Vasiu <alexandru.vasiu@ni.com>2018-04-20 15:48:29 +0300
committerArmin Kuster <akuster808@gmail.com>2018-05-01 18:17:02 -0700
commitae3081affdbded8da0fdedd5f059e4d44117613b (patch)
treef78602b2c9f0fb8620d6bc2faecffffb4c2dc1e5 /meta-python
parent9eb8b9a2c416da018c4a8acb416ef38797436f50 (diff)
downloadmeta-openembedded-ae3081affdbded8da0fdedd5f059e4d44117613b.tar.gz
python-configparser: add new recipe
This module provides the ConfigParser class which implements a basic configuration language which provides a structure similar to what’s found in Microsoft Windows INI files. Signed-off-by: Alexandru Vasiu <alexandru.vasiu@ni.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-configparser.inc11
-rw-r--r--meta-python/recipes-devtools/python/python-configparser_3.5.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-configparser_3.5.0.bb2
3 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-configparser.inc b/meta-python/recipes-devtools/python/python-configparser.inc
new file mode 100644
index 0000000000..c1fb8582c3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-configparser.inc
@@ -0,0 +1,11 @@
+SUMMARY = "This module provides the ConfigParser class which implements a basic configuration language which provides a structure similar to what’s found in Microsoft Windows INI files."
+SECTION = "devel/python"
+HOMEPAGE = "https://docs.python.org/3/library/configparser.html"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
+
+SRC_URI[md5sum] = "cfdd915a5b7a6c09917a64a573140538"
+SRC_URI[sha256sum] = "5308b47021bc2340965c371f0f058cc6971a04502638d4244225c49d80db273a"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-configparser_3.5.0.bb b/meta-python/recipes-devtools/python/python-configparser_3.5.0.bb
new file mode 100644
index 0000000000..69f045dbab
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-configparser_3.5.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-configparser.inc
diff --git a/meta-python/recipes-devtools/python/python3-configparser_3.5.0.bb b/meta-python/recipes-devtools/python/python3-configparser_3.5.0.bb
new file mode 100644
index 0000000000..770cba5962
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-configparser_3.5.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-configparser.inc