aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-05-24 13:11:49 +0100
committerKhem Raj <raj.khem@gmail.com>2022-05-29 06:39:14 -0700
commit3e0e2277a2894d6401e1ea8470f2c9441cbf80a4 (patch)
treea54ebc8f98a049806de84832ba4fe7f184aeec94 /meta-python
parent4aebf7e4b226621f4ffe531b8a34510cf3b13742 (diff)
downloadmeta-openembedded-3e0e2277a2894d6401e1ea8470f2c9441cbf80a4.tar.gz
python3-editables: add new recipe
Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-editables_0.3.bb11
2 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index f56022ef59..722e716dd1 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -106,6 +106,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-dominate \
python3-dynamic-dispatch \
python3-ecdsa \
+ python3-editables \
python3-editor \
python3-email-validator \
python3-engineio \
diff --git a/meta-python/recipes-devtools/python/python3-editables_0.3.bb b/meta-python/recipes-devtools/python/python3-editables_0.3.bb
new file mode 100644
index 0000000000..b42ff06872
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-editables_0.3.bb
@@ -0,0 +1,11 @@
+SUMMARY = "A Python library for creating editable wheels"
+HOMEPAGE = "https://github.com/pfmoore/editables"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=41bc1be47b7bb8240db3ef928c7cb0bf"
+
+SRC_URI[sha256sum] = "167524e377358ed1f1374e61c268f0d7a4bf7dbd046c656f7b410cde16161b1a"
+
+inherit pypi python_setuptools_build_meta
+
+BBCLASSEXTEND = "native nativesdk"