aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-14 07:07:42 -0700
committerKhem Raj <raj.khem@gmail.com>2021-05-17 08:52:24 -0700
commit7de9c498be8a0487ef6503081bdb9e0278c3e8f6 (patch)
treefa03af77f5986af1049ea63700da24375cf17403 /meta-python
parentf2dd5227245bd1c9f6e40b41b2df298ff27d80b3 (diff)
downloadmeta-openembedded-7de9c498be8a0487ef6503081bdb9e0278c3e8f6.tar.gz
python3-m2crypto: Fix build on riscv and mips
wordlen is not so easy to calculate on RISCV, therefore pass the right ingredients so compiler does the right thing in the end Do same for mips as well Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb b/meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb
index ef123075c7..e1f92928c6 100644
--- a/meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb
+++ b/meta-python/recipes-devtools/python/python3-m2crypto_0.37.1.bb
@@ -36,6 +36,9 @@ SWIG_FEATURES_x32 = "-D__ILP32__"
SWIG_FEATURES ?= "-D__${HOST_ARCH}__ ${@['-D__ILP32__','-D__LP64__'][d.getVar('SITEINFO_BITS') != '32']}"
+SWIG_FEATURES_append_riscv64 = " -D__SIZEOF_POINTER__=${SITEINFO_BITS}/8 -D__riscv_xlen=${SITEINFO_BITS}"
+SWIG_FEATURES_append_riscv32 = " -D__SIZEOF_POINTER__=${SITEINFO_BITS}/8 -D__riscv_xlen=${SITEINFO_BITS}"
+SWIG_FEATURES_append_mipsarch = " -D_MIPS_SZPTR=${SITEINFO_BITS}"
export SWIG_FEATURES
BBCLASSEXTEND = "native"