aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-08-16 13:17:30 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-08-16 13:17:36 +0200
commitce678f6b079e524bdc7ddd2162dd2e189dcb0ae4 (patch)
treeab76dc5384a6f6dc24f8ed912e0eaffe675a4176 /meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend
parent3e6bb696c4f37aa006dfb455aba31c1620ce89e3 (diff)
downloadmeta-openembedded-ce678f6b079e524bdc7ddd2162dd2e189dcb0ae4.tar.gz
cronie: rename bbappend to match new version from oe-core
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend')
-rw-r--r--meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend
new file mode 100644
index 0000000000..8f45f3ee52
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.11.bbappend
@@ -0,0 +1,17 @@
+# look for files in the layer first
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+inherit systemd
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "crond.service"
+
+SRC_URI += "file://crond.service"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/crond.service ${D}${systemd_unitdir}/system
+}
+