aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-02-13 17:25:35 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-12 18:49:55 +0200
commit313f0ae25925caead4f588695ac9c9bcf00b2755 (patch)
tree1c167bd3cecfa253e438fefd045db110e2fa4cad /meta-systemd/oe-core
parent0afa2a51d2720ed1d6c06aaef17bd90248ef650e (diff)
downloadmeta-openembedded-313f0ae25925caead4f588695ac9c9bcf00b2755.tar.gz
meta-systemd: Append ${PN} to SYSTEMD_SERVICE
When using systemd class from OE-Core we also need to install the units explicitly. systemd packages ending with -systemd are consumed and now provided by package proper. MJ: fix RPROVIDES_PN = PN-systemd in entrance MJ: add RPROVIDES for ntp*-systemd in ntp MJ: the same for wpa-supplicant Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/oe-core')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend7
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend5
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend5
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend22
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend5
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend13
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend10
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend16
-rw-r--r--meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend5
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend7
10 files changed, 62 insertions, 33 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
index d41ca93bfc..ec0f08d93b 100644
--- a/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
@@ -2,8 +2,9 @@ PRINC := "${@int(PRINC) + 1}"
inherit systemd
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE = "avahi-daemon.service"
+SYSTEMD_PACKAGES = "${PN}"
+RPROVIDES_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "avahi-daemon.service"
SYSTEMD_AUTO_ENABLE = "enable"
-FILES_${PN}-systemd += "${systemd_unitdir}/system/"
+FILES_${PN} += "${systemd_unitdir}/system/"
diff --git a/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend b/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
index 8945a6da79..004c4945a9 100644
--- a/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
@@ -4,6 +4,7 @@ inherit systemd
EXTRA_OECONF += "--with-systemdunitdir=${systemd_unitdir}/system/"
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE = "bluetooth.service"
+SYSTEMD_PACKAGES = "${PN}"
+RPROVIDES_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "bluetooth.service"
SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend b/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
index b94f84b2f9..37c0d29198 100644
--- a/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
@@ -1,4 +1,5 @@
PRINC := "${@int(PRINC) + 1}"
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE_${PN}-systemd = "connman.service"
+SYSTEMD_PACKAGES = "${PN}"
+RPROVIDES_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "connman.service"
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
index fde2426593..aec1dfbe94 100644
--- a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
@@ -5,12 +5,26 @@ inherit systemd
PRINC := "${@int(PRINC) + 1}"
-SYSTEMD_PACKAGES = "dhcp-server-systemd dhcp-relay-systemd dhcp-client-systemd"
-SYSTEMD_SERVICE_dhcp-server-systemd = "dhcpd.service"
-SYSTEMD_SERVICE_dhcp-relay-systemd = "dhcrelay.service"
-SYSTEMD_SERVICE_dhcp-client-systemd = "dhclient.service"
+SYSTEMD_PACKAGES = "dhcp-server dhcp-relay dhcp-client"
+SYSTEMD_SERVICE_dhcp-server = "dhcpd.service"
+SYSTEMD_SERVICE_dhcp-relay = "dhcrelay.service"
+SYSTEMD_SERVICE_dhcp-client = "dhclient.service"
+
+FILES_dhcp-server += "${systemd_unitdir}/system/dhcpd.service"
+FILES_dhcp-relay += "${systemd_unitdir}/system/dhrelay.service"
+FILES_dhcp-client += "${systemd_unitdir}/system/dhclient.service"
+RPROVIDES_dhcp-server += "dhcp-server-systemd"
+RPROVIDES_dhcp-relay += "dhcp-relay-systemd"
+RPROVIDES_dhcp-client += "dhcp-client-systemd"
SRC_URI += "file://dhcpd.service \
file://dhclient.service \
file://dhcrelay.service \
"
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/dhcpd.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/dhclient.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/dhcrelay.service ${D}${systemd_unitdir}/system
+}
+
diff --git a/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend b/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
index a061b52c58..9923708019 100644
--- a/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
@@ -2,6 +2,7 @@ PRINC := "${@int(PRINC) + 1}"
inherit systemd
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE = "ofono.service"
+SYSTEMD_PACKAGES = "${PN}"
+RPROVIDES_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "ofono.service"
SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
index a4590657d8..fe5c919063 100644
--- a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
@@ -2,9 +2,18 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
PRINC := "${@int(PRINC) + 1}"
-SYSTEMD_PACKAGES = "openssh-sshd-systemd"
-SYSTEMD_SERVICE = "sshd.socket"
+SYSTEMD_PACKAGES = "openssh-sshd"
+SYSTEMD_SERVICE_openssh-sshd = "sshd.socket"
+FILES_openssh-sshd += "${systemd_unitdir}/system/sshd.socket"
+RPROVIDES_openssh-sshd += "openssh-sshd-systemd"
inherit systemd
SRC_URI += "file://sshd.socket file://sshd@.service file://sshdgenkeys.service"
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_unitdir}/system
+}
+
diff --git a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
index c0276a391b..281c44043b 100644
--- a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
@@ -4,8 +4,14 @@ PRINC := "${@int(PRINC) + 1}"
inherit systemd
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE = "portmap.service"
+SYSTEMD_PACKAGES = "${PN}"
+RPROVIDES_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "portmap.service"
SYSTEMD_AUTO_ENABLE = "disable"
SRC_URI_append = " file://portmap.service"
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/portmap.service ${D}${systemd_unitdir}/system
+}
+
diff --git a/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
index a94b00725a..d0ce87eb03 100644
--- a/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
@@ -1,15 +1,3 @@
-PRINC := "${@int(PRINC) + 2}"
+PRINC := "${@int(PRINC) + 3}"
-inherit systemd
-
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE = "wpa_supplicant.service"
-SYSTEMD_AUTO_ENABLE = "disable"
-
-do_install_append () {
- install -d ${D}${systemd_unitdir}/system
- install -m 644 ${S}/wpa_supplicant/systemd/*.service ${D}${systemd_unitdir}/system
-}
-
-# systemd.bbclass does not catch all multiple-instance-service-files
-FILES_${PN}-systemd += "${systemd_unitdir}/system/"
+RPROVIDES_${PN} += "${PN}-systemd"
diff --git a/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend b/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend
index 809a554390..e0b1abaf73 100644
--- a/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend
+++ b/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend
@@ -4,5 +4,6 @@ PRINC := "${@int(PRINC) + 1}"
SYSTEMD_UNITDIR = "${systemd_unitdir}/system"
EXTRA_OECONF += "--enable-socket-activation --with-systemdsystemunitdir=${SYSTEMD_UNITDIR}"
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE = "uuidd.socket"
+SYSTEMD_PACKAGES = "${PN}"
+RPROVIDES_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "uuidd.socket"
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
index 0e08358b29..89079dcae1 100644
--- a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
@@ -7,4 +7,11 @@ inherit systemd
SRC_URI += "file://lighttpd.service"
SYSTEMD_PACKAGES = "${PN}"
+RPROVIDES_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "lighttpd.service"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
+}
+