aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-09-17 08:15:47 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-17 10:42:35 +0200
commit4d234731b2770f8983f16ba22177ed022fe8eea9 (patch)
tree70824fe72de69e19f72659529c34ae09046a8722 /meta-systemd
parent72335a05f2b9a47aceec9e6f3881cd7209224343 (diff)
downloadmeta-openembedded-4d234731b2770f8983f16ba22177ed022fe8eea9.tar.gz
lxdm: initial add 1.22_git
* use git version since 1.21 missing escape button and bugfixes * no init-scripts (I am working with systemd -> testing causes huge efforts -> subsequent patches) * run tested on overo/xfce Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/meta-oe/recipes-graphics/lxdm/lxdm/lxdm.service.in10
-rw-r--r--meta-systemd/meta-oe/recipes-graphics/lxdm/lxdm_git.bbappend16
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-systemd/meta-oe/recipes-graphics/lxdm/lxdm/lxdm.service.in b/meta-systemd/meta-oe/recipes-graphics/lxdm/lxdm/lxdm.service.in
new file mode 100644
index 0000000000..0bc6774f32
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-graphics/lxdm/lxdm/lxdm.service.in
@@ -0,0 +1,10 @@
+[Unit]
+Description=LXDE Display Manager
+After=systemd-user-sessions.service
+
+[Service]
+ExecStart=%sbindir%/lxdm
+StandardOutput=syslog
+
+[Install]
+Alias=display-manager.service
diff --git a/meta-systemd/meta-oe/recipes-graphics/lxdm/lxdm_git.bbappend b/meta-systemd/meta-oe/recipes-graphics/lxdm/lxdm_git.bbappend
new file mode 100644
index 0000000000..e4cf44d3ff
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-graphics/lxdm/lxdm_git.bbappend
@@ -0,0 +1,16 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+PRINC := "${@int(PRINC) + 1}"
+
+inherit systemd
+
+SRC_URI += "file://lxdm.service.in"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ sed -e 's,%sbindir%,${sbindir},g' \
+ < ${WORKDIR}/lxdm.service.in \
+ > ${D}${systemd_unitdir}/system/lxdm.service
+}
+
+SYSTEMD_PACKAGES = "${PN}-systemd"
+SYSTEMD_SERVICE = "lxdm.service"