aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-12-18 21:15:57 +0000
committerEric Bénard <eric@eukrea.com>2013-01-07 12:00:26 +0100
commitebd90bda129afef410d8a760aa0456390d67b319 (patch)
tree823a7abae34dfbce29f34f91aa7f0a16198b92bb /meta-systemd
parent7776c45a15a73644e4c0485592959e3a95611a68 (diff)
downloadmeta-openembedded-ebd90bda129afef410d8a760aa0456390d67b319.tar.gz
xinput-calibrator: Fix service file to require display-manager.service
The xinput-calibrator.service had a requires to xserver-nodm.service but in fact it ought to wait by any display-manager to be initialized. We fix it changing the require to display-manager.service. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator.service4
-rw-r--r--meta-systemd/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend2
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-systemd/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator.service b/meta-systemd/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator.service
index e23bfc4f1f..23018768d9 100644
--- a/meta-systemd/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator.service
+++ b/meta-systemd/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator.service
@@ -1,8 +1,8 @@
[Unit]
Description=Loads xinput calibration data
ConditionPathExists=/etc/pointercal.xinput
-Requires=xserver-nodm.service
-After=xserver-nodm.service
+Requires=display-manager.service
+After=display-manager.service
[Service]
ExecStart=/usr/bin/xinput_calibrator_once.sh
diff --git a/meta-systemd/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend b/meta-systemd/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend
index e12abec4cc..5bc5bc3848 100644
--- a/meta-systemd/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend
+++ b/meta-systemd/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend
@@ -1,6 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
inherit systemd