aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-10-29 17:28:48 -0700
committerKhem Raj <raj.khem@gmail.com>2013-01-08 09:31:52 -0800
commitdc75cb086d6f3c79c4ab2371ac36e9c829032e94 (patch)
treed1b53568bd6a78f2d571a0e3a2b265e5101a1989 /meta-systemd
parent845f6dccafb6eb9c5e89b7b14319c951f7a96c24 (diff)
downloadmeta-openembedded-dc75cb086d6f3c79c4ab2371ac36e9c829032e94.tar.gz
rpcbind: Add systemd service unit file
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind/rpcbind.service13
-rw-r--r--meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend12
2 files changed, 25 insertions, 0 deletions
diff --git a/meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind/rpcbind.service b/meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind/rpcbind.service
new file mode 100644
index 0000000000..a028acebe5
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind/rpcbind.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=RPC Bind
+After=network.target
+Wants=rpcbind.target
+Before=rpcbind.target
+
+[Service]
+Type=forking
+ExecStart=/usr/sbin/rpcbind
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend b/meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend
new file mode 100644
index 0000000000..0fa7f97610
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-extended/rpcbind/rpcbind_0.2.0.bbappend
@@ -0,0 +1,12 @@
+inherit systemd
+
+PRINC := "${@int(PRINC) + 1}"
+
+# look for files in the layer first
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://rpcbind.service"
+
+SYSTEMD_PACKAGES = "${PN}-systemd"
+SYSTEMD_SERVICE = "rpcbind.service"
+