aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2/apache2-2.4.3/fix-libtool-name.patch
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2012-11-25 18:25:05 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-11-27 10:48:22 +0000
commit5b3749ca143c5e2a957d1509d65164e191a92883 (patch)
tree4a982d00b4450b2729eca6018a7f4c03ba0df9f5 /meta-webserver/recipes-httpd/apache2/apache2-2.4.3/fix-libtool-name.patch
parent5b427f6daae0caa7439256ecf35a877f1cb2dbed (diff)
downloadmeta-openembedded-5b3749ca143c5e2a957d1509d65164e191a92883.tar.gz
apache2: upgrade to 2.4.3
Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2/apache2-2.4.3/fix-libtool-name.patch')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2-2.4.3/fix-libtool-name.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2-2.4.3/fix-libtool-name.patch b/meta-webserver/recipes-httpd/apache2/apache2-2.4.3/fix-libtool-name.patch
new file mode 100644
index 0000000000..027af04c3b
--- /dev/null
+++ b/meta-webserver/recipes-httpd/apache2/apache2-2.4.3/fix-libtool-name.patch
@@ -0,0 +1,55 @@
+Fix build scripts to use correct libtool filename
+
+Upstream-Status: Inappropriate [configuration]
+
+---
+ httpd-2.4.2/build/config_vars.sh.in | 2 +-
+ httpd-2.4.2/configure | 2 +-
+ httpd-2.4.2/configure.in | 2 +-
+ httpd-2.4.2/support/apxs.in | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+--- a/build/config_vars.sh.in
++++ b/build/config_vars.sh.in
+@@ -35,7 +35,7 @@ else
+ APU_CONFIG=@APU_CONFIG@
+ fi
+
+-APR_LIBTOOL="`${APR_CONFIG} --apr-libtool`"
++APR_LIBTOOL="`${APR_CONFIG} --apr-libtool | sed -e s,libtool,${host_alias}-libtool,`"
+ APR_INCLUDEDIR="`${APR_CONFIG} --includedir`"
+ test -n "@APU_CONFIG@" && APU_INCLUDEDIR="`${APU_CONFIG} --includedir`"
+
+--- a/configure
++++ b/configure
+@@ -6205,7 +6205,7 @@ case $host in
+ if test "x$LTFLAGS" = "x"; then
+ LTFLAGS='--silent'
+ fi
+- my_libtool=`$apr_config --apr-libtool`
++ my_libtool=`$apr_config --apr-libtool | sed -e s,libtool,${host_alias}-libtool,`
+ LIBTOOL="$my_libtool \$(LTFLAGS)"
+ libtoolversion=`$my_libtool --version`
+ case $libtoolversion in
+--- a/configure.in
++++ b/configure.in
+@@ -264,7 +264,7 @@ case $host in
+ if test "x$LTFLAGS" = "x"; then
+ LTFLAGS='--silent'
+ fi
+- my_libtool=`$apr_config --apr-libtool`
++ my_libtool=`$apr_config --apr-libtool | sed -e s,libtool,${host_alias}-libtool,`
+ LIBTOOL="$my_libtool \$(LTFLAGS)"
+ libtoolversion=`$my_libtool --version`
+ case $libtoolversion in
+--- a/support/apxs.in
++++ b/support/apxs.in
+@@ -352,7 +352,7 @@ if ($apr_major_version < 2) {
+ }
+ }
+
+-my $libtool = `$apr_config --apr-libtool`;
++my $libtool = `$apr_config --apr-libtool| sed -e s,libtool,${host_alias}-libtool,`;
+ chomp($libtool);
+
+ my $apr_includedir = `$apr_config --includes`;