aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.27.1.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-webserver/recipes-httpd/sthttpd/sthttpd_2.27.1.bb
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/sthttpd/sthttpd_2.27.1.bb')
-rw-r--r--meta-webserver/recipes-httpd/sthttpd/sthttpd_2.27.1.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.27.1.bb b/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.27.1.bb
index 560dd9b6e4..8a30b74c81 100644
--- a/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.27.1.bb
+++ b/meta-webserver/recipes-httpd/sthttpd/sthttpd_2.27.1.bb
@@ -20,7 +20,7 @@ S = "${WORKDIR}/git"
inherit autotools update-rc.d systemd update-alternatives
ALTERNATIVE_PRIORITY = "100"
-ALTERNATIVE_${PN}-doc = "htpasswd.1"
+ALTERNATIVE:${PN}-doc = "htpasswd.1"
ALTERNATIVE_LINK_NAME[htpasswd.1] = "${mandir}/man1/htpasswd.1"
SRV_DIR ?= "${servicedir}/www"
@@ -29,12 +29,12 @@ SRV_DIR ?= "${servicedir}/www"
# but ${SRV_DIR} is not installed chgrp'd to the group by default.
WEBGROUP ?= "www-data"
-do_configure_prepend () {
+do_configure:prepend () {
export WEBDIR=${SRV_DIR}
export WEBGROUP=${WEBGROUP}
}
-do_install_append () {
+do_install:append () {
install -d ${D}${sysconfdir}/init.d
install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/thttpd
install -c -m 755 ${WORKDIR}/thttpd.conf ${D}${sysconfdir}
@@ -52,7 +52,7 @@ do_install_append () {
INITSCRIPT_NAME = "thttpd"
INITSCRIPT_PARAMS = "defaults"
-SYSTEMD_SERVICE_${PN} = "thttpd.service"
+SYSTEMD_SERVICE:${PN} = "thttpd.service"
-FILES_${PN} += "${SRV_DIR}"
-FILES_${PN}-dbg += "${SRV_DIR}/cgi-bin/.debug"
+FILES:${PN} += "${SRV_DIR}"
+FILES:${PN}-dbg += "${SRV_DIR}/cgi-bin/.debug"