aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2019-09-10 17:58:24 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-10 06:54:01 -0700
commit540df694e4093cec392bac36b4553e8b9db6ac93 (patch)
tree00937c78aabd9a3a57257bb6c470b8532a9b2a0c /meta-webserver/recipes-httpd
parent54983c1351ef12d6fa0ef1a61ed6a6b3a4087951 (diff)
downloadmeta-openembedded-540df694e4093cec392bac36b4553e8b9db6ac93.tar.gz
apache-websocket: fix module path
The apache2 module's path has been changed from ${libdir} to ${libexecdir} in commit 8d4d608b4e937bb3b8e3b260bd75338c3ff7e8fd. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd')
-rw-r--r--meta-webserver/recipes-httpd/apache-mod/apache-websocket_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-webserver/recipes-httpd/apache-mod/apache-websocket_git.bb b/meta-webserver/recipes-httpd/apache-mod/apache-websocket_git.bb
index c44efb6cd1..3cbab22c3d 100644
--- a/meta-webserver/recipes-httpd/apache-mod/apache-websocket_git.bb
+++ b/meta-webserver/recipes-httpd/apache-mod/apache-websocket_git.bb
@@ -25,9 +25,9 @@ EXTRA_OECONF = "APACHECTL=${STAGING_DIR_TARGET}${sbindir}/apachectl \
LIBTOOL=${STAGING_DIR_TARGET}${bindir_crossscripts}/${HOST_SYS}-libtool"
do_install() {
- install -d ${D}${libdir}/apache2/modules
- install -m 755 ${B}/.libs/mod_websocket.so ${D}${libdir}/apache2/modules
+ install -d ${D}${libexecdir}/apache2/modules
+ install -m 755 ${B}/.libs/mod_websocket.so ${D}${libexecdir}/apache2/modules
}
-FILES_${PN} += " ${libdir}/apache2/modules/* "
-FILES_${PN}-dbg += " ${libdir}/apache2/modules/.debug/* "
+FILES_${PN} += " ${libexecdir}/apache2/modules/* "
+FILES_${PN}-dbg += " ${libexecdir}/apache2/modules/.debug/* "