aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorEmmanuel Roullit <emmanuel.roullit@gmail.com>2020-05-04 20:35:33 +0200
committerKhem Raj <raj.khem@gmail.com>2020-05-04 14:03:55 -0700
commiteaf4a9d8a770cc0d1a19a5866a33ce25cba065ce (patch)
tree0be60bef485e990d0d0409d411b24ddf70370758 /meta-webserver
parent7d137c5b21913e7d86851124f8f259dff409f9ed (diff)
downloadmeta-openembedded-eaf4a9d8a770cc0d1a19a5866a33ce25cba065ce.tar.gz
cockpit: fix metainfo.xml file ownership
The 'tar -cf - | tar -xf' combo applies an invalid ownership. This is corrected by patching the install target to use the --no-same-owner tar parameter. Signed-off-by: Emmanuel Roullit <emmanuel.roullit@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/cockpit_218.bb4
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/files/0003-install-fix-metainfo.xml-ownership-on-install.patch30
2 files changed, 31 insertions, 3 deletions
diff --git a/meta-webserver/recipes-webadmin/cockpit/cockpit_218.bb b/meta-webserver/recipes-webadmin/cockpit/cockpit_218.bb
index 863793a21a..4ddffb4bdf 100644
--- a/meta-webserver/recipes-webadmin/cockpit/cockpit_218.bb
+++ b/meta-webserver/recipes-webadmin/cockpit/cockpit_218.bb
@@ -8,6 +8,7 @@ SRC_URI += " \
https://github.com/cockpit-project/cockpit/releases/download/${PV}/cockpit-${PV}.tar.xz \
file://0001-remove-tests-dep-on-gobject-intro.patch \
file://0002-fix-makefile-use-copy-rule-for-unmodified-files.patch \
+ file://0003-install-fix-metainfo.xml-ownership-on-install.patch \
file://cockpit.pam \
"
SRC_URI[md5sum] = "e69b0b8a75a5d55ddfd9817d857c71af"
@@ -165,9 +166,6 @@ RDEPENDS_${PN} += "${PN}-bridge"
do_install_append() {
pkgdatadir=${datadir}/cockpit
- # avoid host contamination
- find ${D}${datadir}/cockpit -name manifest.json -exec chown root:root {} \;
-
chmod 4750 ${D}${libexecdir}/cockpit-session
install -d "${D}${sysconfdir}/pam.d"
diff --git a/meta-webserver/recipes-webadmin/cockpit/files/0003-install-fix-metainfo.xml-ownership-on-install.patch b/meta-webserver/recipes-webadmin/cockpit/files/0003-install-fix-metainfo.xml-ownership-on-install.patch
new file mode 100644
index 0000000000..b967b1c0ad
--- /dev/null
+++ b/meta-webserver/recipes-webadmin/cockpit/files/0003-install-fix-metainfo.xml-ownership-on-install.patch
@@ -0,0 +1,30 @@
+From e56f2b294ca8c805bfd3d715d523bef188c54cb1 Mon Sep 17 00:00:00 2001
+From: Emmanuel Roullit <emmanuel.roullit@gmail.com>
+Date: Sat, 2 May 2020 14:05:35 +0200
+Subject: [PATCH] install: fix metainfo.xml ownership on install
+
+Signed-off-by: Emmanuel Roullit <emmanuel.roullit@gmail.com>
+---
+ Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index d9f918e99..9a23e0a7b 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -226,10 +226,10 @@ maintainer-clean-local::
+
+ install-data-local:: $(WEBPACK_INSTALL)
+ $(MKDIR_P) $(DESTDIR)$(pkgdatadir)
+- tar -cf - $^ | tar -C $(DESTDIR)$(pkgdatadir) --strip-components=1 -xvf -
++ tar -cf - $^ | tar --no-same-owner -C $(DESTDIR)$(pkgdatadir) --strip-components=1 -xvf -
+ install-data-local:: $(WEBPACK_DEBUG)
+ $(MKDIR_P) $(DESTDIR)$(debugdir)$(pkgdatadir)
+- tar -cf - $^ | tar -C $(DESTDIR)$(debugdir)$(pkgdatadir) --strip-components=1 -xvf -
++ tar -cf - $^ | tar --no-same-owner -C $(DESTDIR)$(debugdir)$(pkgdatadir) --strip-components=1 -xvf -
+ uninstall-local::
+ find $(DESTDIR)$(pkgdatadir) -ignore_readdir_race -type f -exec rm -f {} \;
+ find $(DESTDIR)$(pkgdatadir) -ignore_readdir_race -type d -empty -delete
+--
+2.17.1
+