aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-panel-plugins
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-05-19 18:09:32 +0200
committerAndreas Müller <schnitzeltony@googlemail.com>2012-06-08 14:28:20 +0200
commit4c699142d4babeffa8a9294f652e13035d521592 (patch)
tree057aaf804dc03bee13d4e0b1bb72170c47e9673c /meta-xfce/recipes-panel-plugins
parent459860b30a18846066d661fb9a1e79c51c4fe7db (diff)
downloadmeta-openembedded-4c699142d4babeffa8a9294f652e13035d521592.tar.gz
xfce4-cpugraph-plugin: update to 1.0.2
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-xfce/recipes-panel-plugins')
-rw-r--r--meta-xfce/recipes-panel-plugins/cpugraph/files/port-to-libxfce4ui.patch102
-rw-r--r--meta-xfce/recipes-panel-plugins/cpugraph/xfce4-cpugraph-plugin_1.0.2.bb (renamed from meta-xfce/recipes-panel-plugins/cpugraph/xfce4-cpugraph-plugin_1.0.1.bb)6
2 files changed, 2 insertions, 106 deletions
diff --git a/meta-xfce/recipes-panel-plugins/cpugraph/files/port-to-libxfce4ui.patch b/meta-xfce/recipes-panel-plugins/cpugraph/files/port-to-libxfce4ui.patch
deleted file mode 100644
index cb8025a575..0000000000
--- a/meta-xfce/recipes-panel-plugins/cpugraph/files/port-to-libxfce4ui.patch
+++ /dev/null
@@ -1,102 +0,0 @@
-From 2db9e1d1a91ea335bfede19ec513dee69569f60a Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmx.de>
-Date: Tue, 18 Oct 2011 01:43:30 +0200
-Subject: [PATCH] port to libxfce4ui
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-
-Signed-off-by: Andreas Müller <schnitzeltony@gmx.de>
----
- configure.ac | 4 ++--
- panel-plugin/Makefile.am | 4 ++--
- panel-plugin/cpu.c | 4 ++--
- panel-plugin/properties.c | 2 +-
- panel-plugin/settings.c | 2 +-
- 5 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index e20015e..3aa57bb 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -27,8 +27,8 @@ dnl Check for standard header files
- AC_HEADER_STDC
-
- dnl configure the panel plugin
--XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.3.20])
--XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.20])
-+XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.8.0])
-+XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.8.0])
- XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.12.0])
-
- dnl translations
-diff --git a/panel-plugin/Makefile.am b/panel-plugin/Makefile.am
-index 595c61f..6340196 100644
---- a/panel-plugin/Makefile.am
-+++ b/panel-plugin/Makefile.am
-@@ -3,11 +3,11 @@ plugin_PROGRAMS = xfce4-cpugraph-plugin
-
- xfce4_cpugraph_plugin_CFLAGS = \
- -DPACKAGE_LOCALE_DIR=\"$(localedir)\" \
-- @LIBXFCEGUI4_CFLAGS@ \
-+ @LIBXFCE4UI_CFLAGS@ \
- @LIBXFCE4PANEL_CFLAGS@
-
- xfce4_cpugraph_plugin_LDADD = \
-- @LIBXFCEGUI4_LIBS@ \
-+ @LIBXFCE4UI_LIBS@ \
- @LIBXFCE4PANEL_LIBS@
-
- xfce4_cpugraph_plugin_SOURCES = \
-diff --git a/panel-plugin/cpu.c b/panel-plugin/cpu.c
-index 63431f6..1f13b51 100644
---- a/panel-plugin/cpu.c
-+++ b/panel-plugin/cpu.c
-@@ -26,7 +26,7 @@
- #include "mode.h"
- #include "properties.h"
-
--#include <libxfcegui4/libxfcegui4.h>
-+#include <libxfce4ui/libxfce4ui.h>
- #include <libxfce4panel/xfce-hvbox.h>
- #ifndef _
- # include <libintl.h>
-@@ -344,7 +344,7 @@ static gboolean command_cb( GtkWidget *w,GdkEventButton *event, CPUGraph *base )
- {
- if( event->button == 1 && base->command )
- {
-- xfce_exec( base->command, base->in_terminal, base->startup_notification, NULL );
-+ xfce_spawn_command_line_on_screen( gdk_screen_get_default(), base->command, base->in_terminal, base->startup_notification, NULL );
- }
- return FALSE;
- }
-diff --git a/panel-plugin/properties.c b/panel-plugin/properties.c
-index 411fafd..ed191dd 100644
---- a/panel-plugin/properties.c
-+++ b/panel-plugin/properties.c
-@@ -26,7 +26,7 @@
- #include "settings.h"
-
- #include <glib/gprintf.h>
--#include <libxfcegui4/libxfcegui4.h>
-+#include <libxfce4ui/libxfce4ui.h>
-
- #ifndef _
- # include <libintl.h>
-diff --git a/panel-plugin/settings.c b/panel-plugin/settings.c
-index dcc474e..c0f1fed 100644
---- a/panel-plugin/settings.c
-+++ b/panel-plugin/settings.c
-@@ -22,7 +22,7 @@
- * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
- */
- #include "settings.h"
--#include <libxfcegui4/libxfcegui4.h>
-+#include <libxfce4ui/libxfce4ui.h>
-
- static void default_command( const gchar ** command, gboolean * in_terminal, gboolean * startup_notification )
- {
---
-1.7.4.4
-
diff --git a/meta-xfce/recipes-panel-plugins/cpugraph/xfce4-cpugraph-plugin_1.0.1.bb b/meta-xfce/recipes-panel-plugins/cpugraph/xfce4-cpugraph-plugin_1.0.2.bb
index abbc7f1cca..e3bea63fe4 100644
--- a/meta-xfce/recipes-panel-plugins/cpugraph/xfce4-cpugraph-plugin_1.0.1.bb
+++ b/meta-xfce/recipes-panel-plugins/cpugraph/xfce4-cpugraph-plugin_1.0.2.bb
@@ -5,7 +5,5 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=415654f59d8fa70fe4eac2c3f86c8f5e"
inherit xfce-panel-plugin
-# SRC_URI must follow inherited one
-SRC_URI += "file://port-to-libxfce4ui.patch"
-SRC_URI[md5sum] = "ff551087b1f61c47b8746e8687c572aa"
-SRC_URI[sha256sum] = "b5fada35a92083b67818da0ce3fe5ba6a2443fee26d6eec71755ff383df7c407"
+SRC_URI[md5sum] = "93d7658d989ebf110875bc2deb76d7b3"
+SRC_URI[sha256sum] = "b535a9c3d105c0d1597fa4071fe140912bb483c4401c84ad178531fc85de0577"