aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmx.de>2011-11-02 22:50:22 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-03 09:49:46 +0100
commit0c8127413f1b87282a63f89bd663c536716df639 (patch)
treeabba128ba3dc0e3ef3b888167d1172daf970ca2d /meta-xfce
parentb3d7efbc9a1853a953177efd7988069fad3551ef (diff)
downloadmeta-openembedded-0c8127413f1b87282a63f89bd663c536716df639.tar.gz
xfce4-netload-plugin: initial add 1.0.0
* patch taken from xfce-bugzilla [1] * run tested with wlan0 on overo [1] https://bugzilla.xfce.org/show_bug.cgi?id=7083 Signed-off-by: Andreas Müller <schnitzeltony@gmx.de> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-panel-plugins/netload/files/port-to-libxfce4ui.patch72
-rw-r--r--meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.0.0.bb11
2 files changed, 83 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/netload/files/port-to-libxfce4ui.patch b/meta-xfce/recipes-panel-plugins/netload/files/port-to-libxfce4ui.patch
new file mode 100644
index 0000000000..55bdffc3da
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/netload/files/port-to-libxfce4ui.patch
@@ -0,0 +1,72 @@
+From 95fcb98d0189c3f9a051b56416503b42ac29ff90 Mon Sep 17 00:00:00 2001
+From: Christoph J. Thompson <cjsthompson@gmail.com>
+Date: Tue, 11 Jan 2011 16:17:48 +0100
+Subject: [PATCH 1/2] Port to libxfce4ui.
+
+ modified: configure.ac
+ modified: panel-plugin/Makefile.am
+ modified: panel-plugin/netload.c
+---
+ configure.ac | 2 +-
+ panel-plugin/Makefile.am | 4 ++--
+ panel-plugin/netload.c | 5 +++--
+ 3 files changed, 6 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0348bfa..3baaa14 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -56,7 +56,7 @@ dnl configure the panel plugin
+ XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.20])
+
+ dnl configure the libxfcegui4
+-XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.4.0])
++XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.7.0])
+
+ dnl Check for i18n support
+ XDT_I18N([@LINGUAS@])
+diff --git a/panel-plugin/Makefile.am b/panel-plugin/Makefile.am
+index 0635d67..2163277 100644
+--- a/panel-plugin/Makefile.am
++++ b/panel-plugin/Makefile.am
+@@ -17,12 +17,12 @@ xfce4_netload_plugin_SOURCES = \
+ xfce4_netload_plugin_CFLAGS = \
+ -DPACKAGE_LOCALE_DIR=\"$(localedir)\" \
+ @LIBXFCE4PANEL_CFLAGS@ \
+- @LIBXFCEGUI4_CFLAGS@
++ @LIBXFCE4UI_CFLAGS@
+
+ xfce4_netload_plugin_LDADD = \
+ @SOLLIBS@ \
+ @LIBXFCE4PANEL_LIBS@ \
+- @LIBXFCEGUI4_LIBS@
++ @LIBXFCE4UI_LIBS@
+
+ # .desktop file
+ #
+diff --git a/panel-plugin/netload.c b/panel-plugin/netload.c
+index b4868c4..43035f2 100644
+--- a/panel-plugin/netload.c
++++ b/panel-plugin/netload.c
+@@ -30,7 +30,7 @@
+ #include <gtk/gtk.h>
+
+ #include <libxfce4util/libxfce4util.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include <libxfce4panel/xfce-panel-plugin.h>
+
+
+@@ -460,7 +460,8 @@ static void setup_monitor(t_global_monitor *global, gboolean supress_warnings)
+ if (!init_netload( &(global->monitor->data), global->monitor->options.network_device)
+ && !supress_warnings)
+ {
+- xfce_err (_("%s: Error in initalizing:\n%s"),
++ xfce_dialog_show_error (NULL, NULL,
++ _("%s: Error in initalizing:\n%s"),
+ _(APP_NAME),
+ _(errormessages[
+ global->monitor->data.errorcode == 0
+--
+1.7.1
+
diff --git a/meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.0.0.bb b/meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.0.0.bb
new file mode 100644
index 0000000000..a0013b4f59
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/netload/xfce4-netload-plugin_1.0.0.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Panel plugin displaying current load of the network interfaces"
+HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-netload-plugin"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=35a7203c41b86d15546dddc05995f97f"
+
+inherit xfce-panel-plugin
+
+# SRC_URI must follow inherited one
+SRC_URI += "file://port-to-libxfce4ui.patch"
+SRC_URI[md5sum] = "cab53e8cc2b9bfdf7ffd2230916ca3df"
+SRC_URI[sha256sum] = "f312d19fc6bfae525886a1f6e84e7d839f19a9f672be4e01f3df1c813f6a6032"