aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-06-02 13:20:17 +0200
committerAndreas Müller <schnitzeltony@googlemail.com>2012-06-08 14:28:39 +0200
commit7b92e431bbd8585646e2e187cc91d93e3ea81316 (patch)
tree7601d198457fe37d43b69af182193f8546beb738 /meta-xfce
parent62d68daab0233c98681c1ef47ef7db1f28ce7f97 (diff)
downloadmeta-openembedded-7b92e431bbd8585646e2e187cc91d93e3ea81316.tar.gz
xfce4-weather-plugin: Make it work for a while by using different license info
Grabbed from [1] This is a inztermediate solution until next version hopefully will use another weather data supplier. There are proceedings ongoing [2]. [1] https://projects.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/xfce4-weather-plugin [2] http://git.xfce.org/panel-plugins/xfce4-weather-plugin/log/ Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb b/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb
index d75d51e282..202078ee7e 100644
--- a/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb
+++ b/meta-xfce/recipes-panel-plugins/weather/xfce4-weather-plugin_0.7.4.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "Panel plugin to display current temperature and weather condition
HOMEPAGE = "http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+PR = "r1"
inherit xfce-panel-plugin
@@ -9,4 +10,14 @@ SRC_URI += "file://port-to-libxfce4ui.patch"
SRC_URI[md5sum] = "03c972d13eba5cd226432ff66e3ff282"
SRC_URI[sha256sum] = "3f76207b8a845d15bfec6825bd5300aedd086c455259c4dd8670a89a3c8ab382"
+do_compile_prepend() {
+ # Switch to a working license key
+ # https://bugs.archlinux.org/task/26815
+ sed -i \
+ -e 's/^#define PARTNER_ID.*/#define PARTNER_ID "1003666583"/' \
+ -e 's/^#define LICENSE_KEY.*/#define LICENSE_KEY "4128909340a9b2fc"/' \
+ ${S}/panel-plugin/weather.h
+
+}
+
FILES_${PN} += "${datadir}/xfce4/weather"