aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2023-04-13 13:27:14 +0800
committerKhem Raj <raj.khem@gmail.com>2023-04-12 22:52:18 -0700
commitf7a6c2ebdcda78695bb272bed762b8a727777561 (patch)
tree27132343f6b9e73f4a34ce1b4735ada76ee11e69 /meta-xfce
parent73ef8e4ec0468aa9e7dfe8649721ba01445cdcc4 (diff)
downloadmeta-openembedded-f7a6c2ebdcda78695bb272bed762b8a727777561.tar.gz
xfce4-panel: 4.18.0 -> 4.18.3
Update xfce4-panel from 4.18.0 to 4.18.3 * rebase 2 patches Release notes for 4.18.3 ======================== - launcher: Show action menu also when there are several items - Fix memory management of vala generated plugins - panel: Rephrase "Don't reserve space on borders" (V2) - panel: Make property migration generic - launcher: Avoid "no trigger event" warning when showing the menu - launcher: Guard access to the plugin menu GdkWindow - libxfce4panel: Unregister menu also on GtkWidget::hide - panel: Do not reset output name if a monitor does not have a model name - libxfce4panel: Fix memory management of source for menu positioning - panel: Delay removal of ExternalPlugin to prevent use-after-free - systray: Cancel any async D-Bus operation in finalize() - tasklist: Do not try to resolve /proc/pid/exe to launch new instance - Translation Updates: Albanian, Arabic, Armenian (Armenia), Asturian, Basque, Belarusian, Bulgarian, Catalan, Chinese (China), Chinese (Hong Kong), Chinese (Taiwan), Croatian, Czech, Danish, Dutch, Eastern Armenian, English (Australia), English (United Kingdom), Estonian, Finnish, French, Galician, German, Greek, Hebrew, Hungarian, Icelandic, Indonesian, Italian, Japanese, Kazakh, Korean, Lithuanian, Malay, Norwegian Bokmål, Norwegian Nynorsk, Occitan (post 1500), Polish, Portuguese, Portuguese (Brazil), Romanian, Russian, Serbian, Slovak, Slovenian, Spanish, Swedish, Thai, Turkish, Ukrainian, Uyghur, Vietnamese Release notes for 4.18.2 ======================== - directorymenu: Add missing sanity check - panel: Properly handle null string as property default value - Revert "Use RGBA visual only if compositing is enabled (Fixes #251)" (#672) - Revert "systray: Do not require compositing to be enabled to use RGBA visual" - systray: Fix blurry icons in prefs dialog when UI scale &gt; 1 - launcher: Fix blurry icons in prefs and add dialogs when UI scale &gt; 1 - launcher: Use GIcon for the tooltip icon (#674) - pager: Use WnckHandle if available (#695) - Translation Updates: Albanian, Finnish, Greek, Italian, Portuguese, Slovenian Release notes for 4.18.1 ======================== - Update copyright year - tasklist: Fix scrolling through window buttons (Fixes #692) - tasklist: Fix group button visibility - libxfce4panel: Deprecate XfcePanelImage - tasklist: Do not duplicate menu item activation - clock: Fix sync timeout - docs: Fix version for xfce_panel_set_image_from_source() - clock: Add missing sanity check - windowmenu: Adapt wnck default icon size when UI scale &gt; 1 (Fixes #682) - tasklist: Adapt wnck default icon size when UI scale &gt; 1 (Fixes #681) - tasklist: Fix window count positioning when UI scale &gt; 1 - tasklist: Keep icon pixbuf around and use surface also for menu items - clock: Do not override custom font formats - Translation Updates: Albanian, Amharic, Arabic, Armenian (Armenia), Asturian, Basque, Belarusian, Bengali, Bulgarian, Catalan, Chinese (China), Chinese (Hong Kong), Chinese (Taiwan), Croatian, Czech, Danish, Dutch, Eastern Armenian, English (Australia), English (United Kingdom), Estonian, Finnish, French, Galician, Georgian, German, Greek, Hebrew, Hungarian, Icelandic, Indonesian, Interlingue, Italian, Japanese, Kazakh, Korean, Lithuanian, Malay, Norwegian Bokmål, Norwegian Nynorsk, Occitan (post 1500), Panjabi (Punjabi), Polish, Portuguese, Portuguese (Brazil), Romanian, Russian, Serbian, Sinhala, Slovak, Slovenian, Spanish, Swedish, Thai, Turkish, Ukrainian, Uyghur, Vietnamese Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch10
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/files/0002-use-lxdm-to-replace-dm-tool.patch10
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.18.3.bb (renamed from meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.18.0.bb)2
3 files changed, 13 insertions, 9 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
index 10c456f45e..154f72d186 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
+++ b/meta-xfce/recipes-xfce/xfce4-panel/files/0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
@@ -14,7 +14,7 @@ Upstream-Status: Pending
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
-Rebase for xfce4 4.18.0.
+Rebase for xfce4-panel 4.18.3.
Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
@@ -22,10 +22,10 @@ Signed-off-by: Kai Kang <kai.kang@windriver.com>
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/plugins/windowmenu/windowmenu.c b/plugins/windowmenu/windowmenu.c
-index ba245a3..f8fdee8 100644
+index be7dea4..2f432b0 100644
--- a/plugins/windowmenu/windowmenu.c
+++ b/plugins/windowmenu/windowmenu.c
-@@ -250,7 +250,7 @@ window_menu_plugin_init (WindowMenuPlugin *plugin)
+@@ -262,7 +262,7 @@ window_menu_plugin_init (WindowMenuPlugin *plugin)
g_signal_connect (G_OBJECT (plugin->button), "toggled",
G_CALLBACK (window_menu_plugin_menu), plugin);
@@ -33,8 +33,8 @@ index ba245a3..f8fdee8 100644
+ plugin->icon = gtk_image_new_from_icon_name (NULL, GTK_ICON_SIZE_BUTTON);
gtk_container_add (GTK_CONTAINER (plugin->button), plugin->icon);
gtk_widget_show (plugin->icon);
- }
-@@ -680,19 +680,19 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
+
+@@ -695,19 +695,19 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
/* skip 'fake' windows */
type = wnck_window_get_window_type (window);
if (type == WNCK_WINDOW_DESKTOP || type == WNCK_WINDOW_DOCK)
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/files/0002-use-lxdm-to-replace-dm-tool.patch b/meta-xfce/recipes-xfce/xfce4-panel/files/0002-use-lxdm-to-replace-dm-tool.patch
index b06e26e91d..66a33c722a 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/files/0002-use-lxdm-to-replace-dm-tool.patch
+++ b/meta-xfce/recipes-xfce/xfce4-panel/files/0002-use-lxdm-to-replace-dm-tool.patch
@@ -9,15 +9,19 @@ so use lxdm to replace dm-tool
Upstream-Status: Inappropriate [oe specific]
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+
+Rebase for xfce4-panel 4.18.3.
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
plugins/actions/actions.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/plugins/actions/actions.c b/plugins/actions/actions.c
-index 474798e..63eb41d 100644
+index e1f1fa7..440f430 100644
--- a/plugins/actions/actions.c
+++ b/plugins/actions/actions.c
-@@ -905,12 +905,12 @@ actions_plugin_actions_allowed (void)
+@@ -977,12 +977,12 @@ actions_plugin_actions_allowed (void)
GError *error = NULL;
/* check for commands we use */
@@ -32,7 +36,7 @@ index 474798e..63eb41d 100644
g_free (path);
path = g_find_program_in_path ("gdmflexiserver");
if (path != NULL)
-@@ -1027,9 +1027,9 @@ actions_plugin_action_activate (GtkWidget *widget,
+@@ -1099,9 +1099,9 @@ actions_plugin_action_activate (GtkWidget *widget,
break;
case ACTION_TYPE_SWITCH_USER:
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.18.0.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.18.3.bb
index 5dcd69d357..7e70754431 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.18.0.bb
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.18.3.bb
@@ -14,7 +14,7 @@ SRC_URI += " \
file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
file://0002-use-lxdm-to-replace-dm-tool.patch \
"
-SRC_URI[sha256sum] = "be80023fd546587831bab25ded15ae4c9e346289a75744b6ba4cf4ee53794710"
+SRC_URI[sha256sum] = "4ae0b8615c9811194bbda0172a63567ed7fdb5519ea48f7a4637f4e6e5365e1b"
EXTRA_OECONF += "--disable-vala"