aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-07 12:08:20 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-07 12:08:20 +0100
commitfb874704c38c98bbcc2787aa41a2ee46f2a0b465 (patch)
tree4c43b7ecaff6e97c256a2183b64fa47e993dc187 /recipes-connectivity
parentee3afcda723f16630bbe4b2f4c5c0d93c587dd88 (diff)
downloadmeta-openembedded-fb874704c38c98bbcc2787aa41a2ee46f2a0b465.tar.gz
openssl: import 1.0.0c from OE, drop 1.0.0a
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/openssl/ocf-linux.inc23
-rw-r--r--recipes-connectivity/openssl/ocf-linux_20100325.bb6
-rw-r--r--recipes-connectivity/openssl/openssl-1.0.0a/openssl-fix-ssl3_get_key_exchange-double-free.patch12
-rw-r--r--recipes-connectivity/openssl/openssl-1.0.0c/configure-targets.patch (renamed from recipes-connectivity/openssl/openssl-1.0.0a/configure-targets.patch)14
-rw-r--r--recipes-connectivity/openssl/openssl-1.0.0c/debian.patch (renamed from recipes-connectivity/openssl/openssl-1.0.0a/debian.patch)0
-rw-r--r--recipes-connectivity/openssl/openssl-1.0.0c/engines-install-in-libdir-ssl.patch (renamed from recipes-connectivity/openssl/openssl-1.0.0a/engines-install-in-libdir-ssl.patch)0
-rw-r--r--recipes-connectivity/openssl/openssl-1.0.0c/libdeps-first.patch (renamed from recipes-connectivity/openssl/openssl-1.0.0a/libdeps-first.patch)0
-rw-r--r--recipes-connectivity/openssl/openssl-1.0.0c/oe-ldflags.patch (renamed from recipes-connectivity/openssl/openssl-1.0.0a/oe-ldflags.patch)0
-rw-r--r--recipes-connectivity/openssl/openssl-1.0.0c/shared-libs.patch (renamed from recipes-connectivity/openssl/openssl-1.0.0a/shared-libs.patch)0
-rw-r--r--recipes-connectivity/openssl/openssl-native_1.0.0c.bb27
-rw-r--r--recipes-connectivity/openssl/openssl.inc5
-rw-r--r--recipes-connectivity/openssl/openssl_1.0.0c.bb (renamed from recipes-connectivity/openssl/openssl_1.0.0a.bb)13
12 files changed, 79 insertions, 21 deletions
diff --git a/recipes-connectivity/openssl/ocf-linux.inc b/recipes-connectivity/openssl/ocf-linux.inc
new file mode 100644
index 0000000000..9d8e08911c
--- /dev/null
+++ b/recipes-connectivity/openssl/ocf-linux.inc
@@ -0,0 +1,23 @@
+DESCRIPTION = "Install required headers to enable OCF Linux support"
+LICENSE = "BSD"
+
+INC_PR = "r0"
+
+SRC_URI = "http://sourceforge.net/projects/ocf-linux/files/ocf-linux/${PV}/ocf-linux-${PV}.tar.gz"
+
+S = "${WORKDIR}/ocf-linux-${PV}"
+
+# Need to unpack the the ocf-linux.tar.gz file contained inside the
+# downloaded tarball
+do_install_prepend() {
+ cd ${S}
+ tar xzf ocf-linux.tar.gz
+}
+
+# Install the OCF Linux headers so that other packages such as openssl
+# can find them. The headers must be in a crypto directory according to
+# the README file.
+do_install() {
+ install -d ${D}${includedir}/crypto
+ install -m 0644 ${S}/ocf/*.h ${D}${includedir}/crypto/
+}
diff --git a/recipes-connectivity/openssl/ocf-linux_20100325.bb b/recipes-connectivity/openssl/ocf-linux_20100325.bb
new file mode 100644
index 0000000000..9dccc3c32f
--- /dev/null
+++ b/recipes-connectivity/openssl/ocf-linux_20100325.bb
@@ -0,0 +1,6 @@
+require ocf-linux.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "ce5ad54aa94226d496df1f0f3cf0c11f"
+SRC_URI[sha256sum] = "9d17cbd13849939c70699b520280e3b94cf77401cdc131108d4aeaaeea587f6b"
diff --git a/recipes-connectivity/openssl/openssl-1.0.0a/openssl-fix-ssl3_get_key_exchange-double-free.patch b/recipes-connectivity/openssl/openssl-1.0.0a/openssl-fix-ssl3_get_key_exchange-double-free.patch
deleted file mode 100644
index 4e988498a3..0000000000
--- a/recipes-connectivity/openssl/openssl-1.0.0a/openssl-fix-ssl3_get_key_exchange-double-free.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: openssl-1.0.0a/ssl/s3_clnt.c
-===================================================================
---- openssl-1.0.0a.orig/ssl/s3_clnt.c 2010-09-13 18:38:01.000000000 +0400
-+++ openssl-1.0.0a/ssl/s3_clnt.c 2010-09-13 18:38:35.000000000 +0400
-@@ -1508,6 +1508,7 @@
- s->session->sess_cert->peer_ecdh_tmp=ecdh;
- ecdh=NULL;
- BN_CTX_free(bn_ctx);
-+ bn_ctx = NULL;
- EC_POINT_free(srvr_ecpoint);
- srvr_ecpoint = NULL;
- }
diff --git a/recipes-connectivity/openssl/openssl-1.0.0a/configure-targets.patch b/recipes-connectivity/openssl/openssl-1.0.0c/configure-targets.patch
index 112732b3fd..22f8743e7f 100644
--- a/recipes-connectivity/openssl/openssl-1.0.0a/configure-targets.patch
+++ b/recipes-connectivity/openssl/openssl-1.0.0c/configure-targets.patch
@@ -2,11 +2,11 @@
The number of colons are important :)
-Index: openssl-1.0.0/Configure
+Index: openssl-1.0.0a/Configure
===================================================================
---- openssl-1.0.0.orig/Configure 2010-01-19 13:40:54.000000000 -0800
-+++ openssl-1.0.0/Configure 2010-05-26 22:58:01.238104854 -0700
-@@ -380,6 +380,16 @@ my %table=(
+--- openssl-1.0.0a.orig/Configure
++++ openssl-1.0.0a/Configure
+@@ -380,6 +380,22 @@ my %table=(
"linux-alpha-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
"linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${alpha_asm}",
@@ -20,6 +20,12 @@ Index: openssl-1.0.0/Configure
+
+"linux-avr32","$ENV{'CC'}:-DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).",
+
++#### Linux on MIPS/MIPS64
++"linux-mips","$ENV{'CC'}:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"linux-mips64","$ENV{'CC'}:-DB_ENDIAN -DTERMIO -mabi=64 -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"linux-mips64el","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -mabi=64 -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"linux-mipsel","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL DES_RISC2::::::::::::dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++
#### *BSD [do see comment about ${BSDthreads} above!]
"BSD-generic32","gcc:-DTERMIOS -O3 -fomit-frame-pointer -Wall::${BSDthreads}:::BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL:${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
"BSD-x86", "gcc:-DL_ENDIAN -DTERMIOS -O3 -fomit-frame-pointer -Wall::${BSDthreads}:::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_asm}:a.out:dlfcn:bsd-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
diff --git a/recipes-connectivity/openssl/openssl-1.0.0a/debian.patch b/recipes-connectivity/openssl/openssl-1.0.0c/debian.patch
index 1cd6e11966..1cd6e11966 100644
--- a/recipes-connectivity/openssl/openssl-1.0.0a/debian.patch
+++ b/recipes-connectivity/openssl/openssl-1.0.0c/debian.patch
diff --git a/recipes-connectivity/openssl/openssl-1.0.0a/engines-install-in-libdir-ssl.patch b/recipes-connectivity/openssl/openssl-1.0.0c/engines-install-in-libdir-ssl.patch
index 949d6ad8c4..949d6ad8c4 100644
--- a/recipes-connectivity/openssl/openssl-1.0.0a/engines-install-in-libdir-ssl.patch
+++ b/recipes-connectivity/openssl/openssl-1.0.0c/engines-install-in-libdir-ssl.patch
diff --git a/recipes-connectivity/openssl/openssl-1.0.0a/libdeps-first.patch b/recipes-connectivity/openssl/openssl-1.0.0c/libdeps-first.patch
index 1fda69ba93..1fda69ba93 100644
--- a/recipes-connectivity/openssl/openssl-1.0.0a/libdeps-first.patch
+++ b/recipes-connectivity/openssl/openssl-1.0.0c/libdeps-first.patch
diff --git a/recipes-connectivity/openssl/openssl-1.0.0a/oe-ldflags.patch b/recipes-connectivity/openssl/openssl-1.0.0c/oe-ldflags.patch
index 3dd3bedab0..3dd3bedab0 100644
--- a/recipes-connectivity/openssl/openssl-1.0.0a/oe-ldflags.patch
+++ b/recipes-connectivity/openssl/openssl-1.0.0c/oe-ldflags.patch
diff --git a/recipes-connectivity/openssl/openssl-1.0.0a/shared-libs.patch b/recipes-connectivity/openssl/openssl-1.0.0c/shared-libs.patch
index 7cd70d8fdc..7cd70d8fdc 100644
--- a/recipes-connectivity/openssl/openssl-1.0.0a/shared-libs.patch
+++ b/recipes-connectivity/openssl/openssl-1.0.0c/shared-libs.patch
diff --git a/recipes-connectivity/openssl/openssl-native_1.0.0c.bb b/recipes-connectivity/openssl/openssl-native_1.0.0c.bb
new file mode 100644
index 0000000000..8483293b9d
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl-native_1.0.0c.bb
@@ -0,0 +1,27 @@
+require openssl.inc
+
+inherit pkgconfig native
+
+SRC_URI[src.md5sum] = "ff8fb85610aef328315a9decbb2712e4"
+SRC_URI[src.sha256sum] = "f731b36de3edaa361179ae6f449668b248a360e34e31e92902d976e9b9d604eb"
+PR = "${INC_PR}.0"
+
+DEFAULT_PREFERENCE = "-1"
+
+export DIRS = "crypto ssl apps engines"
+
+# This flag can contain target options (e.g -mfpu=neon for armv7-a systems)
+export FULL_OPTIMIZATION = " "
+export BUILD_OPTIMIZATION = " "
+
+SRC_URI += "file://configure-targets.patch \
+ file://shared-libs.patch \
+ file://debian.patch \
+ file://libdeps-first.patch \
+ "
+
+PARALLEL_MAKE = ""
+
+CFLAG += " -Wa,--noexecstack "
+
+NATIVE_INSTALL_WORKS = "1"
diff --git a/recipes-connectivity/openssl/openssl.inc b/recipes-connectivity/openssl/openssl.inc
index 675abc7de2..86b29f0af7 100644
--- a/recipes-connectivity/openssl/openssl.inc
+++ b/recipes-connectivity/openssl/openssl.inc
@@ -1,8 +1,11 @@
DESCRIPTION = "Secure Socket Layer (SSL) binary and related cryptographic tools."
HOMEPAGE = "http://www.openssl.org/"
-LICENSE = "openssl"
SECTION = "libs/network"
+# "openssl | SSLeay" dual license
+LICENSE = "openssl"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=83d26c69f6f0172ee7f795790424b453"
+
SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz;name=src"
S = "${WORKDIR}/openssl-${PV}"
diff --git a/recipes-connectivity/openssl/openssl_1.0.0a.bb b/recipes-connectivity/openssl/openssl_1.0.0c.bb
index cc3a8ab31c..9348e53c88 100644
--- a/recipes-connectivity/openssl/openssl_1.0.0a.bb
+++ b/recipes-connectivity/openssl/openssl_1.0.0c.bb
@@ -1,10 +1,16 @@
inherit pkgconfig
require openssl.inc
-SRC_URI[src.md5sum] = "e3873edfffc783624cfbdb65e2249cbd"
-SRC_URI[src.sha256sum] = "18a9bd1fc02b8ef90dded34fafaa9089baaafef278a19fc4e89c2ab0dcf70f63"
-PR = "${INC_PR}.1"
+# For target side versions of openssl enable support for OCF Linux driver
+# if they are available.
+DEPENDS += "ocf-linux"
+CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
+
+SRC_URI[src.md5sum] = "ff8fb85610aef328315a9decbb2712e4"
+SRC_URI[src.sha256sum] = "f731b36de3edaa361179ae6f449668b248a360e34e31e92902d976e9b9d604eb"
+
+PR = "${INC_PR}.2"
DEFAULT_PREFERENCE = "-1"
@@ -17,7 +23,6 @@ SRC_URI += "file://configure-targets.patch \
file://oe-ldflags.patch \
file://libdeps-first.patch \
file://engines-install-in-libdir-ssl.patch \
- file://openssl-fix-ssl3_get_key_exchange-double-free.patch \
"
PARALLEL_MAKE = ""