aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2010-12-22 13:43:04 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2010-12-22 13:43:04 +0100
commitaa3c2205caf04ae35db589d9467ad817cafb9e4d (patch)
treee173e6fa9ccf8528046cc842cf0eacc81046fb4a /recipes-core
parent48b315fa83a63c1d01b77ffa8b485a322a4559d2 (diff)
downloadmeta-openembedded-aa3c2205caf04ae35db589d9467ad817cafb9e4d.tar.gz
fakeroot: import fakeroot 1.12.4 from OE
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/fakeroot/fakeroot-native_1.12.4.bb21
-rw-r--r--recipes-core/fakeroot/fakeroot/configure-libtool.patch20
-rw-r--r--recipes-core/fakeroot/fakeroot/fix-prefix.patch15
-rw-r--r--recipes-core/fakeroot/fakeroot_1.12.4.bb26
4 files changed, 82 insertions, 0 deletions
diff --git a/recipes-core/fakeroot/fakeroot-native_1.12.4.bb b/recipes-core/fakeroot/fakeroot-native_1.12.4.bb
new file mode 100644
index 0000000000..e6add2bb26
--- /dev/null
+++ b/recipes-core/fakeroot/fakeroot-native_1.12.4.bb
@@ -0,0 +1,21 @@
+require fakeroot_${PV}.bb
+
+SRC_URI += "file://fix-prefix.patch"
+S = "${WORKDIR}/fakeroot-${PV}"
+
+inherit native
+
+EXTRA_OECONF = "--program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+NATIVE_INSTALL_WORKS = "1"
+
+RDEPENDS_${PN} = "util-linux-native"
+
+SRC_URI[md5sum] = "aaefede2405a40c87438e7e833d69b70"
+SRC_URI[sha256sum] = "dbcab1f495b857e67feff882e018ca59958b8d189ff1f76684d28e35463ec29d"
diff --git a/recipes-core/fakeroot/fakeroot/configure-libtool.patch b/recipes-core/fakeroot/fakeroot/configure-libtool.patch
new file mode 100644
index 0000000000..46f7df7025
--- /dev/null
+++ b/recipes-core/fakeroot/fakeroot/configure-libtool.patch
@@ -0,0 +1,20 @@
+Index: fakeroot-1.12.1/configure.ac
+===================================================================
+--- fakeroot-1.12.1.orig/configure.ac
++++ fakeroot-1.12.1/configure.ac
+@@ -2,14 +2,12 @@
+ AC_INIT([fakeroot],[FAKEROOT_VERSION],[schizo@debian.org],[fakeroot])
+ AC_PREREQ(2.61)
+ AC_CONFIG_MACRO_DIR([build-aux])
+-LT_PREREQ(2.1a)
+ AC_CANONICAL_TARGET
+ AM_INIT_AUTOMAKE
+ AM_MAINTAINER_MODE
+ AC_CONFIG_HEADERS([config.h])
+ AC_PROG_MAKE_SET
+-LT_INIT
+-LT_LANG(C)
++AC_PROG_LIBTOOL
+
+ AH_BOTTOM([#if ! HAVE_BUILTIN_EXPECT
+ #define __builtin_expect(x, expected_value) (x)
diff --git a/recipes-core/fakeroot/fakeroot/fix-prefix.patch b/recipes-core/fakeroot/fakeroot/fix-prefix.patch
new file mode 100644
index 0000000000..3c47bd7650
--- /dev/null
+++ b/recipes-core/fakeroot/fakeroot/fix-prefix.patch
@@ -0,0 +1,15 @@
+Index: fakeroot-1.12.1/scripts/fakeroot.in
+===================================================================
+--- fakeroot-1.12.1.orig/scripts/fakeroot.in
++++ fakeroot-1.12.1/scripts/fakeroot.in
+@@ -30,8 +30,8 @@
+ }
+
+ # strip /bin/fakeroot to find install prefix
+-PREFIX=@prefix@
+-BINDIR=@bindir@
++BINDIR=`dirname $0`
++PREFIX=`dirname ${BINDIR}`
+
+ USEABSLIBPATH=@LDPRELOADABS@
+ LIB=lib@fakeroot_transformed@@DLSUFFIX@
diff --git a/recipes-core/fakeroot/fakeroot_1.12.4.bb b/recipes-core/fakeroot/fakeroot_1.12.4.bb
new file mode 100644
index 0000000000..c265749f64
--- /dev/null
+++ b/recipes-core/fakeroot/fakeroot_1.12.4.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org"
+SECTION = "base"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "\
+ ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
+ file://configure-libtool.patch \
+"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${includedir}/fakeroot
+ install -m 644 *.h ${D}${includedir}/fakeroot
+ install -d ${D}${libdir}/libfakeroot/
+ oe_libinstall -so libfakeroot ${D}${libdir}/libfakeroot/
+}
+
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS_${PN} = "util-linux"
+
+
+SRC_URI[md5sum] = "aaefede2405a40c87438e7e833d69b70"
+SRC_URI[sha256sum] = "dbcab1f495b857e67feff882e018ca59958b8d189ff1f76684d28e35463ec29d"