aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2010-11-01 20:24:30 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2010-11-01 20:28:41 +0100
commit6f2cc15148c8604c7a467ecd8c6ef66c2723c649 (patch)
tree1c2093eab482231ac36702ff27e7478fe4e25d16 /recipes-gnome
parenta56151b557805d15ed073db4beb7ed70e22fe0a1 (diff)
downloadmeta-openembedded-6f2cc15148c8604c7a467ecd8c6ef66c2723c649.tar.gz
angstrom-layers: add policykit* to meta-openembedded
Add missing licenses Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes-gnome')
-rw-r--r--recipes-gnome/policykit/policykit-gnome_0.96.bb25
-rw-r--r--recipes-gnome/policykit/policykit_0.96.bb66
2 files changed, 91 insertions, 0 deletions
diff --git a/recipes-gnome/policykit/policykit-gnome_0.96.bb b/recipes-gnome/policykit/policykit-gnome_0.96.bb
new file mode 100644
index 0000000000..8720ea9fec
--- /dev/null
+++ b/recipes-gnome/policykit/policykit-gnome_0.96.bb
@@ -0,0 +1,25 @@
+HOMEPAGE = "http://www.packagekit.org/"
+DEPENDS = "policykit libgnome"
+LICENSE = "LGPLv2"
+
+PR = "r1"
+
+SRC_URI = "http://hal.freedesktop.org/releases/polkit-gnome-${PV}.tar.bz2;name=polkitgnome"
+SRC_URI[polkitgnome.md5sum] = "611cf39fba2945320fc7a9ec49087e69"
+SRC_URI[polkitgnome.sha256sum] = "0d96c8032d658a2e1eef8adfbeafff0f569ef0cf68b35915423acc00873c8a92"
+
+EXTRA_OECONF = " --disable-scrollkeeper \
+ --disable-man-pages \
+ --disable-examples \
+ --disable-gtk-doc \
+ --enable-introspection=no \
+"
+
+S = "${WORKDIR}/polkit-gnome-${PV}"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += " ${datadir}/dbus-1 \
+ ${datadir}/PolicyKit \
+ "
+
diff --git a/recipes-gnome/policykit/policykit_0.96.bb b/recipes-gnome/policykit/policykit_0.96.bb
new file mode 100644
index 0000000000..d2bc3dd255
--- /dev/null
+++ b/recipes-gnome/policykit/policykit_0.96.bb
@@ -0,0 +1,66 @@
+HOMEPAGE = "http://www.packagekit.org/"
+DEPENDS = "eggdbus libpam expat dbus-glib intltool-native"
+LICENSE = "LGPLv2"
+
+PR = "r2"
+
+SRC_URI = "http://hal.freedesktop.org/releases/polkit-${PV}.tar.gz;name=polkit \
+ "
+
+SRC_URI[polkit.md5sum] = "e0a06da501b04ed3bab986a9df5b5aa2"
+SRC_URI[polkit.sha256sum] = "3426ca917210b2a5525732559368c18f983a4c39a6a55c5dddba26071bd8054a"
+
+EXTRA_OECONF = "--with-authfw=pam \
+ --with-os-type=${DISTRO} \
+ --disable-man-pages \
+ --disable-gtk-doc \
+ --enable-introspection=no \
+"
+
+S = "${WORKDIR}/polkit-${PV}"
+
+inherit autotools pkgconfig
+
+do_install_append () {
+ install -d ${D}${localstatedir}/run/PolicyKit
+ sed -i -e s:system:common:g ${D}${sysconfdir}/pam.d/*
+}
+
+FILES_${PN} += " ${datadir}/dbus-1 \
+ ${datadir}/PolicyKit ${datadir}/polkit-1\
+ ${localstatedir}/run/PolicyKit \
+ ${libdir}/polkit-1/extensions/*.so \
+"
+
+FILES_${PN}-dev += " ${libdir}/polkit-1/extensions/*a"
+
+pkg_postinst_${PN} () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+ grep "^polkituser:" /etc/group > /dev/null || addgroup polkituser
+ grep "^polkituser:" /etc/passwd > /dev/null || adduser --disabled-password --system --home /var/run/polkit polkituser --ingroup polkituser -g polkituser
+
+ # Fix owners
+ for i in /etc/polkit-1/localauthority /var/lib/polkit-1 ; do
+ mkdir -p $i
+ chown root $i
+ chmod 700 $i
+ done
+
+ for i in /usr/libexec/polkit-agent-helper-1 /usr/bin/pkexec ; do
+ chown root $i
+ chmod 4755 $i
+ done
+
+ DBUSPID=`pidof dbus-daemon`
+ if [ "x$DBUSPID" != "x" ]; then
+ /etc/init.d/dbus-1 force-reload
+ fi
+}
+
+pkg_postrm_${PN} () {
+ deluser polkituser || true
+ delgroup polkituser || true
+}