aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2010-11-01 19:45:14 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2010-11-01 20:07:14 +0100
commit3327c6130276991eb64e950cae44657aeb21a850 (patch)
tree8d01ba157c0a2fa7469dc21efc926b4e2b17e4a9 /recipes-graphics
parent6b32c02a1480bcb2e7c311ac3c623976565626d8 (diff)
downloadmeta-openembedded-3327c6130276991eb64e950cae44657aeb21a850.tar.gz
angstrom-layers: add font-update-common from OE into meta-openembedded
Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/font-update-common/font-update-common/update-fonts4
-rw-r--r--recipes-graphics/font-update-common/font-update-common_0.1.bb15
2 files changed, 19 insertions, 0 deletions
diff --git a/recipes-graphics/font-update-common/font-update-common/update-fonts b/recipes-graphics/font-update-common/font-update-common/update-fonts
new file mode 100644
index 0000000000..19e3157d2f
--- /dev/null
+++ b/recipes-graphics/font-update-common/font-update-common/update-fonts
@@ -0,0 +1,4 @@
+#!/bin/sh
+#Author: Rolf Leggewie
+
+run-parts /etc/update-fonts-common.d/
diff --git a/recipes-graphics/font-update-common/font-update-common_0.1.bb b/recipes-graphics/font-update-common/font-update-common_0.1.bb
new file mode 100644
index 0000000000..0b5e388b7c
--- /dev/null
+++ b/recipes-graphics/font-update-common/font-update-common_0.1.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Scripts to be called when fonts are installed or removed \
+to make them known to the WM, whether X11 or Opie"
+AUTHOR = "Rolf Leggewie <oe-devel@rolf.leggewie.biz"
+
+LICENSE = "MIT"
+
+SRC_URI = "file://update-fonts"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${sysconfdir}/update-fonts-common.d/
+ install -m 0755 ${WORKDIR}/update-fonts ${D}${bindir}
+}
+
+PACKAGE_ARCH = "all"