aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-07 19:14:47 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-07 19:14:47 +0100
commit7cee3b13087914e1725c909c47a57c5b80dc31dd (patch)
tree3b99dc4de4400a8f035beea2c632e90d7d89aed4 /recipes-graphics
parent2e28165b6bc7756732fd6bb0432b88eeb2f03409 (diff)
downloadmeta-openembedded-7cee3b13087914e1725c909c47a57c5b80dc31dd.tar.gz
xorg-{lib,proto}: sync recipes with yocto for license checksums
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-lib/libxext_1.2.0.bb20
-rw-r--r--recipes-graphics/xorg-lib/libxrender_0.9.6.bb20
-rw-r--r--recipes-graphics/xorg-lib/xorg-lib-common.inc2
-rw-r--r--recipes-graphics/xorg-proto/renderproto_0.11.1.bb15
4 files changed, 37 insertions, 20 deletions
diff --git a/recipes-graphics/xorg-lib/libxext_1.2.0.bb b/recipes-graphics/xorg-lib/libxext_1.2.0.bb
index f4482e652e..3d18d62882 100644
--- a/recipes-graphics/xorg-lib/libxext_1.2.0.bb
+++ b/recipes-graphics/xorg-lib/libxext_1.2.0.bb
@@ -1,12 +1,18 @@
-require xorg-lib-common.inc
DESCRIPTION = "X11 miscellaneous extension library"
-DEPENDS += "xproto virtual/libx11 xextproto libxau"
-PE = "1"
-PR = "${INC_PR}.0"
-SRC_URI[archive.md5sum] = "9bb236ff0193e9fc1c1fb504dd840331"
-SRC_URI[archive.sha256sum] = "4aed3e211e41c47908c293515580e731c26048f61a1212bf0888d1f456de6ff7"
+require xorg-lib-common.inc
+
+LICENSE = "MIT-style"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0542b0321c1c9a7a20b23a1b9fa45f91"
-BBCLASSEXTEND = "native nativesdk"
+DEPENDS += "xproto virtual/libx11 xextproto libxau libxdmcp"
+PROVIDES = "xext"
+
+PR = "r0"
+PE = "1"
XORG_PN = "libXext"
+
+
+SRC_URI[md5sum] = "9bb236ff0193e9fc1c1fb504dd840331"
+SRC_URI[sha256sum] = "4aed3e211e41c47908c293515580e731c26048f61a1212bf0888d1f456de6ff7"
diff --git a/recipes-graphics/xorg-lib/libxrender_0.9.6.bb b/recipes-graphics/xorg-lib/libxrender_0.9.6.bb
index 0828af11f4..c1bb045f86 100644
--- a/recipes-graphics/xorg-lib/libxrender_0.9.6.bb
+++ b/recipes-graphics/xorg-lib/libxrender_0.9.6.bb
@@ -1,13 +1,17 @@
-require xorg-lib-common.inc
DESCRIPTION = "X11 Rendering Extension client library"
-LICENSE = "BSD-X"
-DEPENDS += "virtual/libx11 renderproto xproto libxdmcp"
-PE = "1"
-PR = "${INC_PR}.0"
-SRC_URI[archive.md5sum] = "3b3b7d076c2384b6c600c0b5f4ba971f"
-SRC_URI[archive.sha256sum] = "7f58b1e263109e0a873eef8423aa14733a5499befbe645053aa622ed1f3ea668"
+require xorg-lib-common.inc
+
+LICENSE = "MIT-style"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0db75cc842842b36f097fdae571b4b70"
-BBCLASSEXTEND = "native nativesdk"
+DEPENDS += "virtual/libx11 renderproto xproto xdmcp"
+
+PR = "r0"
+PE = "1"
XORG_PN = "libXrender"
+
+
+SRC_URI[md5sum] = "3b3b7d076c2384b6c600c0b5f4ba971f"
+SRC_URI[sha256sum] = "7f58b1e263109e0a873eef8423aa14733a5499befbe645053aa622ed1f3ea668"
diff --git a/recipes-graphics/xorg-lib/xorg-lib-common.inc b/recipes-graphics/xorg-lib/xorg-lib-common.inc
index 6073621a8b..93212c591f 100644
--- a/recipes-graphics/xorg-lib/xorg-lib-common.inc
+++ b/recipes-graphics/xorg-lib/xorg-lib-common.inc
@@ -15,3 +15,5 @@ S = "${WORKDIR}/${XORG_PN}-${PV}"
inherit autotools pkgconfig
EXTRA_OECONF = "--enable-malloc0returnsnull"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-graphics/xorg-proto/renderproto_0.11.1.bb b/recipes-graphics/xorg-proto/renderproto_0.11.1.bb
index 3b1af5eacc..7e3844847a 100644
--- a/recipes-graphics/xorg-proto/renderproto_0.11.1.bb
+++ b/recipes-graphics/xorg-proto/renderproto_0.11.1.bb
@@ -1,10 +1,15 @@
require xorg-proto-common.inc
-PE = "1"
-PR = "${INC_PR}.0"
-SRC_URI[archive.md5sum] = "a914ccc1de66ddeb4b611c6b0686e274"
-SRC_URI[archive.sha256sum] = "06735a5b92b20759204e4751ecd6064a2ad8a6246bb65b3078b862a00def2537"
+LICENSE = "MIT-style"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f826d99765196352e6122a406cf0d024 \
+ file://renderproto.h;beginline=4;endline=24;md5=3e5e2851dad240b0a3a27c4776b4fd1f"
+
+CONFLICTS = "renderext"
+PR = "r0"
+PE = "1"
BBCLASSEXTEND = "native nativesdk"
-CONFLICTS = "renderext"
+SRC_URI[md5sum] = "a914ccc1de66ddeb4b611c6b0686e274"
+SRC_URI[sha256sum] = "06735a5b92b20759204e4751ecd6064a2ad8a6246bb65b3078b862a00def2537"
+