aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support/mysql/mysql5/Makefile.am.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-03 11:44:38 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-03 12:02:34 +0100
commitef3de09a6bec187e1b6b8db46c55a237ba226a2c (patch)
tree5f843e4bfe14f8334eeb2bc1be7eeb348d49b0b6 /recipes-support/mysql/mysql5/Makefile.am.patch
parent156f6d3dc264c26f743a4359e4d40181a79ba038 (diff)
downloadmeta-openembedded-ef3de09a6bec187e1b6b8db46c55a237ba226a2c.tar.gz
mysql5: import from OE
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-support/mysql/mysql5/Makefile.am.patch')
-rw-r--r--recipes-support/mysql/mysql5/Makefile.am.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-support/mysql/mysql5/Makefile.am.patch b/recipes-support/mysql/mysql5/Makefile.am.patch
new file mode 100644
index 0000000000..33fd17acd4
--- /dev/null
+++ b/recipes-support/mysql/mysql5/Makefile.am.patch
@@ -0,0 +1,19 @@
+Index: mysql-5.1.40/sql/Makefile.am
+===================================================================
+--- mysql-5.1.40.orig/sql/Makefile.am
++++ mysql-5.1.40/sql/Makefile.am
+@@ -174,10 +174,10 @@ link_sources:
+ # This generates lex_hash.h
+ # NOTE Built sources should depend on their sources not the tool
+ # this avoid the rebuild of the built files in a source dist
+-lex_hash.h: gen_lex_hash.cc lex.h
+- $(MAKE) $(AM_MAKEFLAGS) gen_lex_hash$(EXEEXT)
+- ./gen_lex_hash$(EXEEXT) > $@-t
+- $(MV) $@-t $@
++GEN_LEX_HASH = ./gen_lex_hash$(EXEEXT)
++
++lex_hash.h: gen_lex_hash$(EXEEXT)
++ $(GEN_LEX_HASH) > $@
+
+ # For testing of udf_example.so
+ udf_example_la_SOURCES= udf_example.c