aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain-layer
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-03-28 01:54:22 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-29 16:14:38 +0200
commit444c13d1f114c59c7ff568f0313cacc8e67362a1 (patch)
tree3c480be8070db8d34f5a2cce723888893ad3de09 /toolchain-layer
parentd110784db8e78f9b1aa877e3e9228792d34f4583 (diff)
downloadmeta-openembedded-444c13d1f114c59c7ff568f0313cacc8e67362a1.tar.gz
gcc-4.5: Fix meta-toolchain builds with gcc 4.5
Correct a typo Make license parsable by license manage Fixes messages like WARNING: libgcc-nativesdk: No generic license file exists for: RUNTIME in any provider WARNING: libgcc-nativesdk: No generic license file exists for: LIBRARY in any provider WARNING: libgcc-nativesdk: No generic license file exists for: EXCEPTION in any provider NOTE: package libgcc-nativesdk-4.5-r48+svnr184907: task do_populate_lic: Succeeded Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'toolchain-layer')
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc-4.5.inc4
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-4.5.inc b/toolchain-layer/recipes-devtools/gcc/gcc-4.5.inc
index b23b3224b3..ee4a434072 100644
--- a/toolchain-layer/recipes-devtools/gcc/gcc-4.5.inc
+++ b/toolchain-layer/recipes-devtools/gcc/gcc-4.5.inc
@@ -4,7 +4,7 @@ ARM_INSTRUCTION_SET = "arm"
DEPENDS =+ "mpfr gmp libmpc elfutils"
NATIVEDEPS = "mpfr-native gmp-native gettext-native libmpc-native elfutils-native"
-LICENSE="GCC RUNTIME LIBRARY EXCEPTION & GPLv2 & GPLv3 & LGPLv2.1 & LGPLv3"
+LICENSE="GPL-3.0-with-GCC-exception & GPLv2 & GPLv3 & LGPLv2.1 & LGPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
file://COPYING3;md5=d32239bcb673463ab874e80d47fae504 \
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
PV = "4.5"
-PR = "r47"
+PR = "r48"
# BINV should be incremented after updating to a revision
# after a minor gcc release (e.g. 4.5.1 or 4.5.2) has been made
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb
index 97e1a2bcbb..0afc90735e 100644
--- a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb
+++ b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.5.bb
@@ -11,7 +11,7 @@ RDEPENDS_${PN} += "mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
SYSTEMHEADERS = "/usr/include"
SYSTEMLIBS = "/lib/"
-SYSTEMLIB. = "/usr/lib/"
+SYSTEMLIBS1 = "/usr/lib/"
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
--disable-libgomp --disable-libmudflap \