aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-connectivity/krb5/krb5_1.11.bb39
-rw-r--r--meta/recipes-connectivity/krb5/krb5_1.8.5.bb39
2 files changed, 39 insertions, 39 deletions
diff --git a/meta-oe/recipes-connectivity/krb5/krb5_1.11.bb b/meta-oe/recipes-connectivity/krb5/krb5_1.11.bb
new file mode 100644
index 0000000000..b1bb32a471
--- /dev/null
+++ b/meta-oe/recipes-connectivity/krb5/krb5_1.11.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "A network authentication protocol"
+HOMEPAGE = "http://web.mit.edu/Kerberos/"
+SECTION = "console/network"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${S}/../NOTICE;md5=e8fad1d174de32f8da0ddc56b67b6941"
+DEPENDS = "ncurses util-linux e2fsprogs-native"
+
+inherit autotools binconfig perlnative
+
+SRC_URI = "http://web.mit.edu/kerberos/dist/${PN}/${PV}/${P}-signed.tar"
+SRC_URI[md5sum] = "1a13c53899806c4da99a798a04d25545"
+SRC_URI[sha256sum] = "fe37fb93b398db98a1b23f814673ea2ae4b90138f85e1a4027ef639456a78651"
+
+S = "${WORKDIR}/${P}/src/"
+
+EXTRA_OECONF += " --without-tcl --with-system-et --disable-rpath"
+CACHED_CONFIGUREVARS += "krb5_cv_attr_constructor_destructor=yes ac_cv_func_regcomp=yes \
+ ac_cv_printf_positional=yes ac_cv_file__etc_environment=yes \
+ ac_cv_file__etc_TIMEZONE=no"
+
+CFLAGS_append += "-DDESTRUCTOR_ATTR_WORKS=1 -I${STAGING_INCDIR}/et"
+LDFLAGS_append += "-lpthread"
+
+FILES_${PN}-doc += "${datadir}/examples"
+FILES_${PN} += "${datadir}/gnats"
+
+krb5_do_unpack() {
+ # ${P}-signed.tar contains ${P}.tar.gz.asc and ${P}.tar.gz
+ tar xzf ${WORKDIR}/${P}.tar.gz -C ${WORKDIR}/
+}
+
+python do_unpack() {
+ bb.build.exec_func('base_do_unpack', d)
+ bb.build.exec_func('krb5_do_unpack', d)
+}
+
+do_configure() {
+ oe_runconf
+}
diff --git a/meta/recipes-connectivity/krb5/krb5_1.8.5.bb b/meta/recipes-connectivity/krb5/krb5_1.8.5.bb
deleted file mode 100644
index 2f497a3ced..0000000000
--- a/meta/recipes-connectivity/krb5/krb5_1.8.5.bb
+++ /dev/null
@@ -1,39 +0,0 @@
-DESCRIPTION = "A network authentication protocol"
-HOMEPAGE = "http://web.mit.edu/Kerberos/"
-SECTION = "console/network"
-PR = "r0"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${S}/../README;md5=5595a75ae6fab5f825f579a817baa618"
-DEPENDS = "ncurses util-linux e2fsprogs-native"
-
-inherit autotools binconfig perlnative
-
-SRC_URI = "http://web.mit.edu/kerberos/dist/krb5/1.8/krb5-1.8.5-signed.tar"
-
-S = "${WORKDIR}/${PN}-${PV}/src/"
-
-EXTRA_OECONF += " --without-tcl --with-system-et"
-CACHED_CONFIGUREVARS += "krb5_cv_attr_constructor_destructor=yes ac_cv_func_regcomp=yes \
- ac_cv_printf_positional=yes ac_cv_file__etc_environment=yes \
- ac_cv_file__etc_TIMEZONE=no"
-
-CFLAGS_append += "-DDESTRUCTOR_ATTR_WORKS=1 -I${STAGING_INCDIR}/et"
-LDFLAGS_append += "-lpthread"
-
-FILES_${PN}-doc += ${datadir}/examples
-
-krb5_do_unpack() {
- tar xzf ${WORKDIR}/krb5-1.8.5.tar.gz -C ${WORKDIR}/
-}
-
-python do_unpack() {
- bb.build.exec_func('base_do_unpack', d)
- bb.build.exec_func('krb5_do_unpack', d)
-}
-
-do_configure() {
- oe_runconf
-}
-
-SRC_URI[md5sum] = "48b17caedf19d07d714a8d7a25422c95"
-SRC_URI[sha256sum] = "7d6989efaaf0b3330ce5b329edb1d0bf33250ca78b789fdd117e02c49c238812"