aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp.inc19
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp_git.bb8
2 files changed, 15 insertions, 12 deletions
diff --git a/meta-oe/recipes-support/freerdp/freerdp.inc b/meta-oe/recipes-support/freerdp/freerdp.inc
index d898f46836..65c61c2d43 100644
--- a/meta-oe/recipes-support/freerdp/freerdp.inc
+++ b/meta-oe/recipes-support/freerdp/freerdp.inc
@@ -1,22 +1,25 @@
-# Copyright (C) 2010, 2011 O.S. Systems Software Ltda. All Rights Reserved
+# Copyright (C) 2010-2012 O.S. Systems Software Ltda. All Rights Reserved
# Released under the MIT license
DESCRIPTION = "FreeRDP RDP client"
HOMEPAGE = "http://www.freerdp.com"
-DEPENDS = "virtual/libx11 openssl libxcursor libxv cups alsa-lib pulseaudio pcsc-lite"
+DEPENDS = "virtual/libx11 openssl libxcursor libxv cups alsa-lib pulseaudio pcsc-lite libxkbfile libxinerama"
SECTION = "x11/network"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
INC_PR = "r1"
-inherit pkgconfig autotools
+inherit pkgconfig cmake
-EXTRA_OECONF += "--with-smartcard --with-xvideo"
-
-do_install_append() {
- rm ${D}${libdir}/freerdp/*.a ${D}${libdir}/freerdp/*.la
-}
+EXTRA_OECMAKE += "-DWITH_PULSEAUDIO=ON \
+ -DWITH_PCSC=ON \
+ -DWITH_CUPS=ON \
+ -DWITH_FFMPEG=OFF \
+ -DWITH_CUNIT=OFF \
+ -DWITH_X11=ON \
+ -DWITH_XKBFILE=ON \
+ -DWITH_XINERAMA=ON"
PACKAGES =+ "libfreerdp"
diff --git a/meta-oe/recipes-support/freerdp/freerdp_git.bb b/meta-oe/recipes-support/freerdp/freerdp_git.bb
index 2a3affd4d6..01ab390c8f 100644
--- a/meta-oe/recipes-support/freerdp/freerdp_git.bb
+++ b/meta-oe/recipes-support/freerdp/freerdp_git.bb
@@ -1,4 +1,4 @@
-# Copyright (C) 2010, 2011, O.S. Systems Software Ltda.
+# Copyright (C) 2010-2012, O.S. Systems Software Ltda.
# Released under the MIT license
include freerdp.inc
@@ -7,9 +7,9 @@ inherit gitpkgv
PV = "gitr${SRCPV}"
PKGV = "${GITPKGVTAG}"
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.0"
-SRCREV = "b3eb650c919c4b3b1e5bc12cea6afb05282a7232"
-SRC_URI = "git://github.com/FreeRDP/FreeRDP-old.git;protocol=git"
+SRCREV = "19d4a4276869ec40ee1eef066ac460615734c043"
+SRC_URI = "git://github.com/FreeRDP/FreeRDP.git"
S = "${WORKDIR}/git"