aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend b/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
index 06993025f1..cd6acc826d 100644
--- a/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
+++ b/meta-systemd/oe-core/recipes-core/busybox/busybox_1.20.2.bbappend
@@ -1,6 +1,6 @@
inherit systemd
-PRINC := "${@int(PRINC) + 2}"
+PRINC := "${@int(PRINC) + 3}"
# look for files in the layer first
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
@@ -21,3 +21,7 @@ do_install_append() {
ln -sf /dev/null ${D}${systemd_unitdir}/system/syslog.service
}
FILES_${PN}-syslog += "${systemd_unitdir}/system/syslog.service"
+
+RPROVIDES_${PN}-syslog += "${PN}-syslog-systemd"
+RREPLACES_${PN}-syslog += "${PN}-syslog-systemd"
+RCONFLICTS_${PN}-syslog += "${PN}-syslog-systemd"