aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch29
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch
new file mode 100644
index 0000000000..96f162dd94
--- /dev/null
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Submitted
+
+This patch adds support for arm32.
+
+Signed-off-by: Chunrong Guo <B40290@freescale.com>
+
+--- a/Makefileold 2014-06-17 21:55:23.131058918 -0500
++++ b/Makefile 2014-06-17 21:56:08.726098531 -0500
+@@ -59,6 +59,12 @@
+ TMPLIB32 = lib
+ CPPFLAGS += -DPPC_NO_SEGMENTS
+ else
++ifeq ($(ARCH),arm)
++CC32 = $(CC)
++TMPLIB32 = lib
++ELF32 += armelf_linux_eabi
++CUSTOM_LDSCRIPTS = no
++else
+ ifeq ($(ARCH),armv7l)
+ CC32 = $(CC)
+ TMPLIB32 = lib
+@@ -116,6 +122,7 @@
+ endif
+ endif
+ endif
++endif
+
+ ifdef CC32
+ OBJDIRS += obj32
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index 5645add6b8..879f2a0674 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -14,11 +14,12 @@ SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code \
file://0001-aarch64-fix-cross-compilation.patch \
file://0001-aarch64-fix-page-size-not-properly-computed.patch \
file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \
+ file://arm32-support.patch \
"
S = "${WORKDIR}/git"
-COMPATIBLE_HOST = "(x86_64|powerpc|powerpc64|aarch64).*-linux*"
+COMPATIBLE_HOST = "(x86_64|powerpc|powerpc64|aarch64|arm).*-linux*"
LIBARGS = "LIB32=${baselib} LIB64=${baselib}"
EXTRA_OEMAKE = "'ARCH=${TARGET_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} V=1"