aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-pycocotools_2.0.2.bb12
2 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index b9ab421302..828c7fea5a 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -289,6 +289,7 @@ RDEPENDS_packagegroup-meta-python3 = "\
python3-pybind11-json \
python3-pybluez \
python3-pychromecast \
+ python3-pycocotools \
python3-pycodestyle \
python3-pyconnman \
python3-pycparser \
diff --git a/meta-python/recipes-devtools/python/python3-pycocotools_2.0.2.bb b/meta-python/recipes-devtools/python/python3-pycocotools_2.0.2.bb
new file mode 100644
index 0000000000..ef2a7c589e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pycocotools_2.0.2.bb
@@ -0,0 +1,12 @@
+SUMMARY = "COCO is a large image dataset designed for object detection, segmentation, \
+ person keypoints detection, stuff segmentation, and caption generation."
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://pycocotools/coco.py;beginline=45;endline=45;md5=12cb539683cf245df8b6ce782d78f647"
+
+inherit setuptools3 pypi
+
+SRC_URI[md5sum] = "33858f23c8b99ce8116b70c32f6b6dd9"
+SRC_URI[sha256sum] = "24717a12799b4471c2e54aa210d642e6cd4028826a1d49fcc2b0e3497e041f1a"
+
+DEPENDS = "python3-cython-native python3-numpy-native virtual/crypt"
+RDEPENDS_${PN} = "python3-matplotlib python3-pillow python3-profile"