aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/python/python-distutils-extra.bb2
-rw-r--r--meta-oe/recipes-devtools/python/python3-distutils-extra.bb2
-rw-r--r--meta-python/recipes-connectivity/gateone/gateone_git.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb4
4 files changed, 3 insertions, 9 deletions
diff --git a/meta-oe/recipes-devtools/python/python-distutils-extra.bb b/meta-oe/recipes-devtools/python/python-distutils-extra.bb
index 56dd33d7ff..eb84f74365 100644
--- a/meta-oe/recipes-devtools/python/python-distutils-extra.bb
+++ b/meta-oe/recipes-devtools/python/python-distutils-extra.bb
@@ -2,8 +2,6 @@ require python-distutils-extra.inc
inherit setuptools
-DISTUTILS_INSTALL_ARGS += "--install-lib=${libdir}/${PYTHON_DIR}/site-packages"
-
RDEPENDS_${PN} = "\
python-distutils \
"
diff --git a/meta-oe/recipes-devtools/python/python3-distutils-extra.bb b/meta-oe/recipes-devtools/python/python3-distutils-extra.bb
index af242b8509..5836b090e0 100644
--- a/meta-oe/recipes-devtools/python/python3-distutils-extra.bb
+++ b/meta-oe/recipes-devtools/python/python3-distutils-extra.bb
@@ -4,8 +4,6 @@ inherit setuptools3
S = "${WORKDIR}/python-distutils-extra-${PV}"
-DISTUTILS_INSTALL_ARGS += "--install-lib=${libdir}/${PYTHON_DIR}/site-packages"
-
RDEPENDS_${PN} = "\
python3-setuptools \
"
diff --git a/meta-python/recipes-connectivity/gateone/gateone_git.bb b/meta-python/recipes-connectivity/gateone/gateone_git.bb
index 4577873ded..5d2ca00ef5 100644
--- a/meta-python/recipes-connectivity/gateone/gateone_git.bb
+++ b/meta-python/recipes-connectivity/gateone/gateone_git.bb
@@ -16,9 +16,7 @@ S = "${WORKDIR}/git"
inherit setuptools python-dir systemd update-rc.d
-DISTUTILS_INSTALL_ARGS = "--root=${D} \
- --prefix=${prefix} \
- --install-lib=${PYTHON_SITEPACKAGES_DIR} \
+DISTUTILS_INSTALL_ARGS += " \
--install-data=${PYTHON_SITEPACKAGES_DIR} \
--install-scripts=${bindir} \
--skip_init_scripts"
diff --git a/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb b/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
index 0ca58c7b73..eb42fe978c 100644
--- a/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
+++ b/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
@@ -16,8 +16,8 @@ SRC_URI = "git://github.com/mike-fabian/langtable.git;branch=master \
inherit setuptools3 python3native
-DISTUTILS_INSTALL_ARGS = "--prefix=${D}/${prefix} \
- --install-data=${D}/${datadir}/langtable"
+DISTUTILS_INSTALL_ARGS += " \
+ --install-data=${datadir}/langtable"
FILES_${PN} += "${datadir}/*"